Weird Mail.app accounts problem (and fix)

Discussion in 'Mac Apps and Mac App Store' started by mkrishnan, Jun 21, 2005.

  1. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #1
    Well, since I already fixed this problem with Apple Mail, I am half posting it because I am curious if others experienced it, and half because the post might help someone else.

    System:
    iBook G4/800MHz / 640MB / 40GB HD / AE / BT
    MacOS X 10.4.1 (Tiger)
    Mail.app (2.0.1, build 730)

    Problem description:
    This morning, after initially working fine, accounts in Mail started acting strangely. The accounts appeared and were enabled in the Accounts prefs pane, appeared in the left-hand mailbox bar in Mail, continued receiving new mail, and were able to send mail as well. However, the accounts did not appear in the signatures pane of prefs, and when I used an AppleScript to change mail servers on all accounts, they did not appear in the list as they previously had. When I created messages from the accounts that had disappeared from the list, the messages did not have signatures.

    Things that did not work:
    Restarting Mail, repairing permissions and rebooting

    What did work:
    Manually disabling and re-enabling each account: uncheck the "enable this account" checkbox in the accounts pane, change to another account, and choose to save the change in the pop-up, and repeat for all accounts; close preferences, and then re-open preferences and repeat the procedure, except now re-checking each of the enable checkboxes.

    Interesting. I had not experienced this previously with Mail in Panther or Tiger.... After this fix, I also had to re-apply my set of signatures to each account (the signatures remained in the All Accounts list, but were not in the separate accounts) and the signature choice option (I use At Random) and reset the default SMTP servers for these accounts.
     
  2. stevietheb macrumors 6502a

    stevietheb

    Joined:
    Jan 15, 2004
    Location:
    Houston
  3. mkrishnan thread starter Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Anytime! :)

    I'm just glad, ahem, it never happened to me again. :rolleyes:
     

Share This Page