Well, i screwed up.

Discussion in 'macOS' started by cdsboy, Dec 11, 2006.

  1. cdsboy macrumors newbie

    Joined:
    Jul 8, 2006
    #1
    So it was around 3 in the morning a couple of nights ago... And i somehow convinced myself that the appkit framework needed to be deleted, thinking there was another copy of it on my system. So i deleted it. Then i realized i didn't have a copy of it. Nothing new would start up. So i went and copied it from the os x install cd. Now no new programs will compile because of an error with it. Does anyone know of anything i can install that will give me the latest version of appkit framework?
     
  2. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Joined:
    Feb 25, 2006
    Location:
    Melbourne
    #2
    why dont you try an archive install on your machine, it will fix everything and you keep all your stuff
     
  3. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #3
    After which, run Software Update until it finds no more updates.
     
  4. cdsboy thread starter macrumors newbie

    Joined:
    Jul 8, 2006
    #4
    that sounds like a wonderful idea... How exactly do i go about doing that?

    EDIT: a quick good search told me how. Hope this works...
     
  5. lorductape macrumors 6502

    lorductape

    Joined:
    Jun 23, 2006
    Location:
    t3h usa
    #5
    man when you said "i screwed up" i thought you meant you bought a pc!
     
  6. cdsboy thread starter macrumors newbie

    Joined:
    Jul 8, 2006
    #6
    well, so i did that. Didn't solve my compiling problem. I think something else is wrong.
     

Share This Page