What the fudge happened?!

Discussion in 'Mac Basics and Help' started by Kristenn, Dec 15, 2009.

  1. macrumors 6502

    Joined:
    Aug 30, 2009
    #1
    I get this when i want to move an item to the trash. My school needed me to put Windows XP on my Mac for a few days and I hadn't noticed this till AFTER I removed the Windows partition. What's up?

    I get the finder preferences but nothing there. Do you think a repair premissions would do it?

    I did back up before removing the Windows part of the drive... just in case.


    [​IMG]
     
  2. macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
  3. thread starter macrumors 6502

    Joined:
    Aug 30, 2009
    #3
    I did that. I also restarted my computer and tried repairing disk permissions.

    I think it has something to do with deleting the cache file for google chrome. It seems to come back every time I restart my computer. Odd.
     
  4. Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #4
    Basically there is an issue with the folder that OS X uses to store the trashed items.

    Have you tried restarting? This usualy kicks it into likfe or try what dukebound85 suggested. edit: Too slow at typing

    If that doesn't solve it try opening a finder window and press cmd+shift+g then i that window type "~/.Trash" without the quote marks.

    If it says the folder doesn't exist open up Terminal in your Utilities folder and type "mkdir ~/.Trash/" again without quotes and press enter, then type "killall Finder" without quotes and press enter.

    This recreates the folder and restarts finder.


    If it is there but doesn't work you can try reparing your permissions.edit: Too slow at typing
     
  5. macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    I once saw the same thing happen due to screwed-up permissions on the .Trash folder. xUKHCx's suggestion should work if no folder exists, but I'm pretty sure the Finder will create it when it launches if it doesn't exist. In my case I think I did it the other way around--I deleted that folder then let Finder recreate it.

    So in the event that the folder DOES exist and you're still having trouble, you'd want to use the following command:

    Code:
    rm -R ~/.Trash
    If it complains that you don't have permission to delete that, then that's probably the problem. You can then add "sudo " to the begining of that command (so "sudo rm -R ~/.Trash"), at which point you'll get a password prompt and it should delete it no matter what.

    Once you've removed the .Trash folder, it should re-create automatically if you either log out and back in, or use the force quit dialogue to re-launch Finder. You could also use "mkdir ~/.Trash/", like xUKHCx suggested, to manually recreate it if it doesn't get created automatically.

    In either case, I'd also open Disk Utility and run "Repair Permissions"--it may not help, but if the trash is screwed up something else might be, and it certainly won't hurt anything.
     
  6. thread starter macrumors 6502

    Joined:
    Aug 30, 2009
    #6
    Thanks everyone! The terminal command worked! =D
     
  7. macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #7
    Out of curiosity, which one? A little more detail on exactly what worked is useful for those who may well see something like this again.
     
  8. thread starter macrumors 6502

    Joined:
    Aug 30, 2009

Share This Page