What the heck happened to my Terminal?!

Discussion in 'Mac Apps and Mac App Store' started by Dagless, Nov 12, 2005.

  1. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #1
    ooookay something strange just happened. I loaded up terminal for the first time ever and this happened! just look at the attachment, its on diet pills or something! seriously I cant 'zoom' it, drag the corner, restore to default size, nothing works!

    can ye help? :)
     

    Attached Files:

  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    The drag corner is clearly visible. Why can't you use it?
     
  3. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #3
    Didja try trashing com.apple.Terminal.plist?

    I've also heard of font issues causes problems like this in the Terminal.
     
  4. Dagless thread starter macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #4
    nope! still mini :eek:

    corners don't work.
     
  5. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #5
    Try this:
    Open terminal
    Press command + N for a new window

    If that doesn't work, try this:
    Open Terminal
    One the File bar select Terminal --> Window Setting
    Select Window from the drop down menu
    Make the rows and columns something big like 100x100
    Click Use Settings as default.
    Close Terminal and reload it.
     
  6. Dagless thread starter macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #6
    nope! funny, the columns thing says 2,047 or something massive! even though the window is mini.
     
  7. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #7
    Can you access the Terminal menu? If so choose Windows Settings... to get up the Terminal Inspector, then use the drop down menu to access Window settings. What's the Dimensions set to?

    Edit: Basically just as grapes suggested. I gotta start reading through the entire thread before posting... :eek: ;)
     
  8. portent macrumors 6502a

    Joined:
    Feb 17, 2004
    #8
    That's probably part of the problem. Try reducing it to a normal size (80x25 or so.)
     
  9. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #9
    You're all wrong. :)

    The problem is, you disabled a font that Terminal requires. I believe it's Monaco.

    Quit Termy, re-enable Monaco, open Termy, all should be fat again.
     
  10. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #10
    So if you change the Terminal default font, would it work?
     
  11. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #11
    Unknown.

    But the issue isn't the font that Terminal is using in the actual term window.. it's the font it's attempting to use for the menubar, I believe. And that isn't changable, AFAIK.

    EDIT: Untrue, I just tested and unfortunately, you cannot choose a different font from the prefs (at least I couldn't). The only way to fix it was to re-enable whatever font it was using that you disabled (default is Monaco). After that, you can change the font and disable what you want, provided you don't disable what it's using, or you have to go back through this rigamarole again.

    (And by "prefs", I mean the Window Settings -> Display)
     

Share This Page