What's broken, my 2012 MBA or Apple's USB 3.0 driver?

Discussion in 'Mac Accessories' started by Yawn66, Jul 5, 2012.

  1. Yawn66, Jul 5, 2012
    Last edited: Jul 5, 2012

    macrumors member

    Joined:
    Jun 14, 2012
    #1
    So I got a brand new 2012 11" MBA with 2.0 GHz Core i7, 8GB RAM, 256 GB SSD. When attaching an external HDD I noticed that I only get a USB 3 connection when I plug the disk directly into one of the MBA's USB ports. As soon as I connect the disk to the MBA through a USB 3 hub the disk drops back to USB 2.

    • I've used two different USB 3 hubs. The behavior is the same with both.

    • I've used quality USB 3 cables for the hubs and the disks. No USB2-only cables were involved.

    • The hubs also connected other USB 2 peripherals to the MBA. But removing all the USB 2 stuff didn't change anything.

    • The HDD I was using was a 3.5" WD 1 TB disk installed in a USB 3 SATA dock. I changed to another USB 3 SATA dock from a different manufacturer, but the behavior was the same. No improvement.

    •I checked USB 3 vs. USB 2 using Apple System Profiler, not by measuring transfer rates. Although the rates I saw were consistent with the reported protocol (~ 30 MB/s via USB 2, ~ 80 MB/s via USB 3 probably limited by the HDD and/or SATA-USB dock).

    • The behavior was the same on both USB ports of the MBA.


    So, can anybody tell me what's wrong here? Is my MBA's USB toast or is this some kind of weird thing in Apple's USB 3 driver? My understanding is that a USB 3 hub should ensure USB 3 speeds for all attached devices (as long as the host supports USB 3 obviously). I've never heard that you only get USB 3 speeds for devices attached directly to the host.

    Thanks in advance for any insight and advice. :)
     
  2. macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #2
    You should get around 90% of the performance when using a hub as opposed to a direct connection. Out of interest, what are the hubs that you used? Please include the exact model numbers.
     
  3. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #3
    Thanks for helping out.

    System Profiler reported USB 2 when connected through the hubs so even at best that would have been way less than 90% of the USB 3 speed I saw when connecting the disks directly. 90% of USB 3 would have been fine (the HDD would still be the bottleneck anyway), but dropping back to USB 2 is not acceptable IMHO.

    FYI the hubs I used were
    • D-LINK DUB-1340 USB-HUB 4-PORT USB 3.0
    • STARTECH 4 PORT BLACK SUPERSPEED USB 3.0 HUB UK (ST4300USB3EU)
     
  4. macrumors 68000

    Joined:
    Apr 25, 2012
    #4
    Were the hubs self-powered or bus-powered? If they were bus-powered (no wall-wart), that may cause what you're seeing.

    Also, I found this on the Startech site in the datasheet for that hub: "If used with the Apple Mac OS operating system, this device will function in USB 2.0
    mode only"
    http://it.startech.com/media/products/ST4300USB3EU/PDFs/ST4300USB3EU_Datasheet.pdf

    The D-Link may be similar, there are minimum system requirements noted on the datasheet with no reference to Mac OS X.
    http://www.dlink.com/us/en/home-sol...ts/DU_DUB/DUB-1340/Datasheet/DUB-1340 DS.ashx
     
  5. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #5
    Thanks for chiming in.

    Both hubs were self-powered. I didn't even consider running them bus powered only. And both certainly had power (LEDs on before even connecting to host) while I was running tests.

    I got these devices before Apple released USB 3 so I always figured they were just stating the obvious (a USB 3 hub will work like a USB 2 hub on a USB 2 host) rather than actually stating USB 3 would simply not work with OS X.

    So this appears to be quite a mess. Is this something Apple can/will fix or do we need to conclude that not everything that calls itself USB 3 is actually USB 3? :(
     
  6. macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #6
    The D-Link model is actually the one that I've in my amazon wishlist. This puts a bit of a spanner in the works. I would suggest reporting this via the Apple's feedback page and also to Dlink and Startech.
     
  7. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #7
    Yeah, I should probably report this. Although, I'm a bit surprised there haven't been more widespread reports about this issue. Seems quite serious to me.

    I'm afraid I'll be sending my MBA back. The idea was to have a highly portable machine that I can easily hook up to a screen, KB, mouse, disks, etc. when I'm at the desk. Having to connect using both USB ports and being limited to only one fast external disk is simply not an acceptable solution IMHO. When USB 3 actually behaves like USB 3 should on OS X I'll reconsider. Shame though, I liked the Air. :(
     
  8. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #8
    Reported to Apple.

    Any chance I'll here from them about it or do they never reply to these kinds of reports?
     
  9. macrumors 68000

    Joined:
    Apr 25, 2012
    #9
  10. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #10
    Thanks for the tip, but I have to order things from a few companies my university has contracts with. None of them have it.

    My MBA is going back to Apple. Pickup scheduled for Monday. :(
     
  11. macrumors 6502

    Joined:
    Feb 27, 2008
    Location:
    Oxford, England
    #11
  12. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #12
    Of course, the real issue is not if it's compatible with OS X 10.4 and later, but if it will run connected USB 3 devices at USB 3 speeds on a Mac.
     
  13. macrumors member

    billib

    Joined:
    Apr 23, 2009
    Location:
    USA
    #13
    Just want to make sure I understand correctly.
    The OP has a peripheral product that doesn't
    work properly with Apple products so Apple
    is to blame. Solving this compatibility issue
    requires purchasing an inexpensive HUB that
    will work but the OP can't afford an inexpensive
    HUB that is slightly higher in price than the
    HUB thats incompatible...........so the
    MacBook Air must be returned.

    Have I got that right?

    This isn't a serious thread!!!!!
    If it is then the OP is going to have a very HARD life.
     
  14. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #14
    I think you're missing the point.

    The described behavior is unique to my MBA running OS X. The same hub/disk setup on my Linux PC works as you'd expect and delivers full USB 3 performance. Therefore, the issue is either my MBA being defective (so far nobody seems to assume that) or the USB 3 driver Apple built into OS X. In either case, the peripherals work as designed. It's the Mac's USB 3 that obviously doesn't (so far).

    Rest assured, the thread is serious and my life is not that hard at all. :)
     
  15. macrumors regular

    Joined:
    Jan 5, 2012
    Location:
    Texas
    #15
    Not saying this will work but...

    I had an issue with FW800 transfer rates being throttled to FW400 on my 2011 Mini and it would not switch back. I did a PRAM reset and got the speed back.

    You may want to retest each hub again with PRAM resets in-between, simple search will show how to do this, and don't hook up any USB 2 peripherals. Couldn't hurt to try. Use something like Blackmagic Disk Speed Test to verify the speed.

    Good luck.
     
  16. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #16
    Thanks for the PRAM suggestion. I guess it would be worth a try. Unfortunately, the MBA is already packed up ready to go back to Apple.

    Oh well, hopefully they'll fix the USB driver issue with the next Lion update (or Mac compatible USB 3 hubs start showing up) and I can order another MBA. This time a 13" though. Or maybe a rMBP after all. ;)
     
  17. macrumors G4

    Joined:
    Oct 23, 2010
    #17
    My guess is that it's the driver. Remember, USB 3.0 support is brand new for Apple, and it is courtesy of a brand new Intel chipset. There could well be bugs that are being worked out.
     
  18. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #18
    I very much hope you're right.

    And I do think you are. I achieved USB 3.0 performance on my MBA as soon as I plugged in the disk directly to the Mac. So the ports were probably ok. Additionally, Apple Hardware Test never reported any issues on this brand new MBA. That does point to a driver issue or at the very least an incompatibility between the MBA and the two USB 3.0 hubs I was testing.

    I hope I'll read something about "USB 3.0 stability and performance improvements" in the release notes for the 10.7.5 update. :)
     
  19. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #19
    Can anybody here test if the just released update fixes incompatibilities between the new Macs and USB 3 devices attached to USB 3 hubs?

     
  20. macrumors member

    Joined:
    Jun 23, 2012
    Location:
    Tel Aviv, Israel
    #20
    Second that!!
     
  21. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #21
    I was able to play with a rMBP yesterday. I didn't see any issues with the USB 3 dock attached through a USB 3 hub to the rMBP. The rMBP had had the update applied already. So I can't say if the USB 3 issues were gone because the update fixed something or because the rMBP didn't have the problem in the first place.
     
  22. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #22
    So the just released MacBook update apparently addresses USB device compatibility. Anybody notice any differences after applying the update?

     
  23. macrumors 6502

    Joined:
    Jul 2, 2007
    #23
    Which hub worked? Please give us the make & model number. Thanks.
     
  24. thread starter macrumors member

    Joined:
    Jun 14, 2012
    #24
    This is what the receipt said

    STARTECH 4 PORT BLACK SUPERSPEED USB 3.0 HUB UK (ST4300USB3EU)
     
  25. macrumors 68040

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #25
    My wife has a white Trendnet 4 port USB 3 hub on her fMBP that works very well. We got it at MicroCenter.
     

Share This Page