What's the latest version of iTunes for a G3?

Discussion in 'PowerPC Macs' started by parish, Apr 9, 2012.

  1. macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Messages:
    1,082
    Location:
    Wilts., UK
    #1
    Installed Tiger on my iMac G3 and the first time I ran iTunes it said there was an u/g to 10.6.1 available. Not convinced 10 will run on a G3 I checked the iTunes page on apple.com and, sure enough, 10.6.1 is for Intel, G4, & G5. There's a link for G3 Mac Users which says 8.2.1 is for G3s so I d/l and installed that.

    When I run this it still says 10.6.1 is available and do I want to d/l it. Will this actually run on a G3 or is the upgrade checker broken?
     
  2. macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Messages:
    1,814
    Location:
    Wales, UK
    #2
    9.2.1 is the latest version of iTunes that will run on Tiger, & therefore your iMac.

    10.6 requires 10.5.8
     
  3. macrumors 6502a

    Starfighter

    Joined:
    Jun 17, 2011
    Messages:
    659
    Location:
    Sweden
    #3
    I thought iTunes always looked for available updates no matter what if it isn't specifically turned off in preferences (Edit -> Preferences -> Check for iTunes updates automatically). Maybe I'm wrong but that's how I've got my iTunes-versions to stop nagging me in older systems.
     
  4. macrumors 65816

    parish

    Joined:
    Apr 14, 2009
    Messages:
    1,082
    Location:
    Wilts., UK
    #4
    I take it that's a typo - should be 8 not 9?

    That's what the iTunes website says, hence my confusion that iTunes keeps offering the update - I thought it would be smart enough to only offer updates that are applicable to your hardware and OS version

    ----------

    Yes, you can turn it off and I will do
     
  5. macrumors 6502

    Joined:
    Mar 26, 2009
    Messages:
    446
    Location:
    Michigan, USA
    #5
  6. macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Messages:
    1,814
    Location:
    Wales, UK
    #6
    Yes, sorry, 8.2.1, I type too fast for my fingers :p
     
  7. macrumors 6502

    ppcg4mac

    Joined:
    Feb 13, 2012
    Messages:
    372
    Location:
    Somewhere Else
    #7
    My tiger running G4s tell me that there is a update every week.
     
  8. macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Messages:
    1,814
    Location:
    Wales, UK
    #8
    iTunes picks up a newer version available, regardless of the system and/or whether you meet system reqs. etc.
     
  9. macrumors 65816

    vohdoun

    Joined:
    Jan 23, 2006
    Messages:
    1,035
    Location:
    Far away from Earth.
    #9
    Turn it off in the iTunes preferences under General.
     
  10. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Messages:
    18,174
    Location:
    Inside
    #10
    While the iTunes page says the latest for G3's is 8.2.1, 9.2.1 runs just fine if you can get past the installer screen. Only a few things like iTunes Extras don't work. But the majority of it works just fine on any speed G3 as long as it's running Tiger.
     
  11. macrumors 65816

    AQUADock

    Joined:
    Mar 20, 2011
    Messages:
    1,040
    #11
    Also to install it use pacifist.
     
  12. macrumors 6502

    MAC MAN JW

    Joined:
    Jul 12, 2011
    Messages:
    298
    Location:
    Buffalo,Ny
    #12
    I used to use iTunes 9.2.1 on my G3 B&W tower and it worked fine. i installed iTunes 9.2.1 on my iMac G3 and when i clicked the iTunes icon on the dock it said something like "iTunes 9 Needs a PowerPc G4 Or G5 CPU To Run" it is very hard to get iTunes 9 uninstalled(Had to use cleanmymac) you can not just go back to iTunes 8:)
     
  13. macrumors member

    Joined:
    Dec 4, 2011
    Messages:
    75
    #13
    I've seen this message with iTunes 9.2.1 as well, didn't work when I last tried to run it on a G3 - 9.1 works fine if you download that and install it though. You won't see it in Software Update as it won't try to push it to a G3, but if you download and install it manually it should be fine, there aren't even any checks in the installer so no need to use Pacifist to install it.
     
  14. macrumors 6502

    MAC MAN JW

    Joined:
    Jul 12, 2011
    Messages:
    298
    Location:
    Buffalo,Ny
    #14
     
  15. macrumors newbie

    Joined:
    Dec 28, 2010
    Messages:
    4
    #15
    Could you please tell me how to use Pacifist to install it? I have tried but it's rather confusing!

    Thank you :)
     
  16. macrumors 65816

    AQUADock

    Joined:
    Mar 20, 2011
    Messages:
    1,040
    #16
    First right click on the iTunes.dmg and open it with Pacifist
    [​IMG]
    you should get this:
    [​IMG]
    Click on "Contents of iTunes.mpkg" and click install on the top.
    Then check "Use Administrator Privileges" and click on install.
    [​IMG]
    This window will pop up twice just select replace and check "Dont ask again...."
    [​IMG]
    When its finished you can launch iTunes.
     

Share This Page