When Loading Music into iTune my album is split up

Discussion in 'Digital Audio' started by ironsides44, Jun 3, 2010.

  1. macrumors newbie

    Joined:
    Jun 3, 2010
    #1
    I am new using a Mac. I am used to using Windows media for my CDs. I have never had a problem loading my CDs in Windows media; however I am having problems with iTunes. When I load an album in iTunes, often it will separate out several songs and show them in different views. I want them all in one view. Is this possible? If so how to I set it up to do this?
     
  2. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What kind of view(s) do you mean specifically?

    Is that album some kind of compilation, which has several artists?

    Have you tried the column browser yet?

    [​IMG]

    [​IMG]

    Look in the VIEW menu item for more.

    Also have a look at the following links, as the information presented there might be helpful in your future endeavours into Mac OS X and could clear up initial confusion and may even prevent harm to your system or your files.


    Mac OS X Basics


    Switch 101 - guide with articles made by Apple on how to accustom yourself, after you switched to Mac OS X from Windows​


    Mac 101 - How to get started with Mac OS X​


    Find out how - tutorial videos made by Apple on how to do certain thing in Mac OS X​


    Pro tips - tips made available by Apple for easier ways of doing certain tasks​


    Mac OS X Keyboard Shortcuts - Learn about common Mac OS X keyboard shortcuts.​


    Mac OS X Beginner's Guide by MacRumors - learn about software, media players, shortcuts and some useful tips, tricks and hints​


    Mac Guides - tutorials, product guides and more​


    MRoogle - a very effective tool to search these fora using Google and made available by edesignuk, introductory threads: 1, 2 and 3
     
  3. thread starter macrumors newbie

    Joined:
    Jun 3, 2010
    #3
    When Loading Music into iTune my album is split up

    Spinnerlys, Thanks for the reply. The below image shows what I’m talking about. I want to use the view menu has it easier to copy an entire album just by highlighting it and then copying it onto a CD or DVD. Windows media allows this it never separates out an album. If you look closely you’ll see that the album Brassed Off is separated out five times; the album Neil Diamond is separated twice. I suppose I could use columns to do this but I’m not sure. Why does that separate these albums out and why can’t I just have one album instead of five or two in the examples below?
     

    Attached Files:

  4. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    You can drag and drop via the browser too, if you burn via playlist for example.

    Or you change the artists of those albums.




    Or you do this, which I just found by looking.

    [​IMG]
     
  5. macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
    #5
    Same happens to me. Same CD, same artist, all same info in columns but sometimes it still splits up like it's different CD. I wish I would know. Hope somebody know how to fix this.
     
  6. macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
  7. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #7
    Come again please?

    My music is in MP3 format too, just with lots and lots of bits (320kbit/s), and it still worked (the last option). The renaming should work too though, as an .mp3 file is still writable (the tag).

    Or what do you mean specifically by your maybe?
     
  8. macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
    #8
    I mean not Itunes format. I just tried to apply every thing exactly same way. My songs still separate as it is different CD's Only difference that I like to keep songs as list. I don't think it should make difference
     
  9. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #9
    I don't understand, MPEG-2 Layer 3 (.mp3 suffix) is not the iTunes format, AAC (.m4a suffix) is. ([​IMG] I think I understand the iTunes format comment now, as the format does not have anything to do with your issue, right?)


    If you use List View, you can also use the Column Browser (look into the VIEW menu) or just sort by album via clicking the ALBUM column.

    Or are we still not on the same side?
     
  10. macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
    #10
    I got that MP3 part, thanks.
    What I like when in list view I see picture of Album, next song name, next Artist, then Album etc. Some Albums have no problems, some do even if all information i columns is the same, except songs names.
     
  11. macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #11

    Is the artist name spelled IDENTICALLY in every album track. Identically means withthe same exact string. Same number of spaces and same punctuation. Notice that "somename" is not the same artist as "somename and someother"

    iTunes is not smart enough to know that "J Smith", "Smith, J" and "Jim S" are all the same person. The best way to enure the names are the same is to use cut and past. There is also an "album artist" field that you can set.

    If the names are not the same you have to check the box for "compilation" or fix the names.
     
  12. macrumors G3

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #12
    I would also look at the composure section, is there information going in that section also? This has happened a few times with me.
     
  13. macrumors 68000

    wesk702

    Joined:
    Jul 7, 2007
    Location:
    The hood
    #13
    If it is what I think ur talking about here is the solution.
    Highlight all ur tracks for the album. Next, right click and select get info. Then, put in a name for the "album artist". Thtis should bring all the items together. Make sure its all the same album name too.

    Hope thats what u were looking for.
     

Share This Page