Where did my safari and Camera app go?

Discussion in 'Jailbreaks and iOS Hacks' started by iMeat, Jan 31, 2011.

  1. macrumors member

    Joined:
    Jul 10, 2008
    #1
    I have a iphone 4 jb with 4.1 I have lost my camera and safari app??? I try to restore with 4.1 but it says my device is not eligible for this restore??
     
  2. macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Well, if what you want is to restore, you are going to need to have your SHSH save if you want to restore back to 4.1, if you just want to go to 4.2.1, itunes should do the trick.

    As far as the App goes, are the app completely gone? or just their icons? Can you get to safari using a link (on an email or something) or maybe using spotlight?
     
  3. macrumors 65816

    Fuzzy14

    Joined:
    Nov 19, 2006
    Location:
    Renfrew, Scotland
    #3
    Dragged into a folder? (sorry if too obvious but my kids do it to me all the time)
     
  4. macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #4
    You didn't happen to use PkgBackup or anything did you? SSH into your phone and look in the Application folder to see if the mobilesafari folders exist.
     
  5. thread starter macrumors member

    Joined:
    Jul 10, 2008
    #5
    No they are completly gone, its very weird. If i try and link through email or something, nothing happens. Even my flashlight app just closes right away, I guess it is hooked up with the camera. I have been jailbroken for a long time, no idea why this just now happened.

    Im just smart enough to jailbreak and use mywi lol, so im not sure how i do the shsh save. I really just want to restore and then jailbrake back to 4.1
     
  6. macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #6
    if you have sb settings installed open it up, go to more.
    then go down to the poof and see if they are hidden.

    Also if you know where the application directories are in your phone look and see if they are there
     
  7. macrumors member

    Joined:
    Aug 16, 2010
    #7
    I had this issue with the camera app alone last month. One day Snappy started freezing the phone every time it was opened. After removing it, I discovered the camera app icon was gone, though it could still be found and opened with Spotlight. It's as if it were hidden by SBSettings, but it didn't show up in the Hide Icons menu.

    Updating to 4.2.1 fixed the missing camera icon, but not Snappy. I'm not sure the two are even related.
     
  8. macrumors 603

    Carlanga

    Joined:
    Nov 5, 2009
    Location:
    PR
    #8
    try to find it under a spotlight search and see if it pops up, if it's there then it's either in a folder or hidden...
     
  9. thread starter macrumors member

    Joined:
    Jul 10, 2008
    #9
    ok a little research later, seems that my exchange account i set up killed it. wonder if there is a way around this
     

Share This Page