Where is my dvd player icon?

Discussion in 'OS X' started by yojimbothe3rd, Mar 13, 2007.

  1. macrumors newbie

    Joined:
    Mar 4, 2007
    #1
    If you can't tell I'm very new to OS X, about 24 hours in fact. I was trying to play a region 2 dvd with the vlc player. I'm aware this can no longer be done, correct me if I'm wrong. I was in finder and I dragged the dvd icon that is in the upper left corner when you have a dvd in over to the vlc player. It went poof and disappeared. How can I get it back? I wouldn't know how to even take the dvd out of the machine now.

    Thanks
     
  2. macrumors 6502a

    tyr2

    Joined:
    May 6, 2006
    Location:
    Leeds, UK
    #2
    Click on 'Macintosh HD' on the column on the left. And then choose 'Enclosing Folder' on the 'Go' menu. You'll then see the drive in the column on the right, just drag it back on where you want it.
     
  3. macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #3
    Welcome to the wonderful world of Macintosh.

    Since you dragged the icon off and it went poof... There should be an icon DVD icon on the desktop. So drag it back on. :)

    You can also eject disc with the eject key on the keyboard.
     
  4. thread starter macrumors newbie

    Joined:
    Mar 4, 2007
    #4
    It is not on the desktop and I did try the eject button but a faint ejection icon pops up in the middle of the screen and nothing really happens.

    Also open enclosing folder didn't work.

    Is there something I'm missing?

    Thanks
     
  5. macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #5
    Thats odd. Are you sure the DVD is still in there? :p

    When you're in the Finder, hit command+",". The preference window should appear. Under the "General" section make sure the "CDs, DVD, and iPods" box is ticked.

    Then go to the "Sidebar" section and make sure the "Removable media" box is ticked.

    If the DVD still doesn't show up, restart while holding down the mouse button.
     
  6. thread starter macrumors newbie

    Joined:
    Mar 4, 2007
    #6
    :p Actually I did think of that, haha. Double checked though and yeah it's not back in the case yet.

    Well "CDs, DVD, and iPods" was checked. In Sidebar, removable media was not checked but I checked it and nothing happened except a few apps I just downloaded that were on the desktop returned.

    Should I try to reboot and see if it returns?
     
  7. macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #7
    You have to quit anything that is using the DVD before ejecting it. Also, it should be on your desktop, from which you can drag the DVD icon to the trash and it will eject (this is actually the old man traditional Mac way of ejecting disks, recently surpassed by the eject button on the recent keyboards).

    Also, why jump so fast to VLC? Did you even try the built in Apple DVD player software?
     
  8. thread starter macrumors newbie

    Joined:
    Mar 4, 2007
    #8
    Ha, that got the DVD out. VLC was still on, I didn't realize it would make a difference but it makes sense.

    I still do not see the cd/dvd icon. I did notice something though. Under finder then preferences there is a list under new finder windows open and a few things show up there. The first three things are "Computer" "Macintosh HD" and "idisk." But the idisk listed is faint (unclickable). I don't know if this helps.

    I've used the built in software a few times but like I said I was trying to play region 2 disk when my computer is region 1. I was under the impression, wrongly, that it may be possible with the VLC player.
     
  9. thread starter macrumors newbie

    Joined:
    Mar 4, 2007
    #9
    Well I put another dvd in and it's back. Thanks for all of your help. I'm excited to learn all of the ins and outs, I should be there by this weekend right? ;)
     

Share This Page