Where to drop Bluecop's repository file in XBMC

Discussion in 'Apple TV and Home Theater' started by X-rated, Feb 20, 2011.

  1. macrumors member

    Joined:
    Apr 30, 2010
    #1
    I havent got a specific answer but I am trying to figure out where to drop the ZIP file so I can unzip it. When I SSH i see lots of files. I assume it will go into the Media file but i am not sure which sub folder to drop it in.
     
  2. macrumors regular

    ISO:HELP

    Joined:
    Oct 23, 2006
    #2
    hey man..

    there is a great thread around here that will help you..

    drag and drop that entire zip file unzipped....as is..into the part that says media..


    ssh into your device>mobile>media
     
  3. macrumors regular

    Joined:
    Jan 12, 2004
    #3
    You want to drop it into /private/var/mobile.

    From XBMC go to Add-Ons - Install from zip file, then click on home directory and you'll see it there.
     
  4. jtt
    macrumors regular

    Joined:
    Apr 10, 2005
    #4
    Why would I not have that directory on either of my Mac's? :eek:
     
  5. macrumors regular

    ISO:HELP

    Joined:
    Oct 23, 2006
    #5


    you open ssh?
     
  6. macrumors 6502

    Joined:
    Jul 14, 2008
    #6
    I have the repo .zip file on my local hdd. whats the ssh command to transfer the repo file on my local hdd to the atv2 using ssh? i already have navigated, via ssh, to the /private/var/mobile directory. I just need to know the ssh command to put the file in this directory. I tried apt-get install with no luck.
     
  7. macrumors regular

    ISO:HELP

    Joined:
    Oct 23, 2006
    #7

    try this

    http://forums.macrumors.com/showthread.php?t=1095898&page=2
     
  8. macrumors regular

    Joined:
    Jan 12, 2004
    #8
    Get cyberduck - it's a free download. Then choose the SFTP connection and log in to your Apple TV the same as if you were doing via SSH - i.e. plug in your ip, ands log in as root and password. It's a great, easy interface and you'll see how to navigate to the private/var/mobile directory. Then, from the Action menu, choose upload and upload the zip file from your HD to the ATV.
     
  9. macrumors 6502

    Joined:
    Jul 14, 2008
    #9
    So i was able to get cyberduck installed and the bluecop repo file transferred into the atv, thank you. trying to navigate and install the repo file in xbmc a little bit challenging. i can see the file when i select the option "install from zip file" and select the file and hit enter and nothing happens? where should i see the changes applied when installing the zip?
     
  10. macrumors regular

    Joined:
    Jan 12, 2004
    #10
    XBMC has a bit of learning curve and this is part of it. I believe the zip file just adds the repository to XBMC - it doesn't add any of the add-ons contained in it. To add the add-ons, (I don't have XBMC in front of me so I'm trying to remember) but go to Videos on the home page then open up the sub-menu of that (I think it's the down arrow on the apple remote). Then, on the sub-menu, click through till you see Add-ons. Open that up, and I believe that that is where you can choose which add-ons to enable from that repository. Once they're enabled, you can play them from the main menu (or perhaps you play them from the Video menu/sub-menu - I forget). The point is, that you first have to enable the various add-ons first.
     
  11. macrumors 6502

    Joined:
    Jul 14, 2008
    #11
    Tried this again but didnt work. For some reason I cant seem to get the addons to be enabled.
     
  12. macrumors regular

    Joined:
    Jan 12, 2004
    #12
    My mistake - sorry. from home, go to Addons - Get Add-ons. You should see the repository there. Click on the repository and then select the add-ons you want.
     
  13. macrumors 6502

    Joined:
    Jul 14, 2008
    #13
    I must be doing something very wrong because I dont see any of the add ons outside of the default ones which were installed by xbmc. Sorry for the pain. The addons that I am looking to get are hulu and cbs. went to this website but for some reason cant figure out how to get the addons working.

    http://forum.xbmc.org/showthread.php?t=79148
     
  14. macrumors regular

    Joined:
    Jan 12, 2004
    #14
    Navigation might be different depending upon which skin you are using. But this is how I did it.
    1. Unzip the repository zip file - you've done that.
    2. From the home page, move to Videos and then select the sub-menu. On the Apple Remote, that's the down button.
    3. On the sub menus you'll see the Addons menu. Click that.
    4. Click Get More...
    5. Click Video Add-ons
    You should then see a list of the Add-ons from that repository. Select the ones you want and install them.

    The problem is, that my navigation through the screens may be well be different from yours depending upon the skin you're using and depending upon previously selected choices I may have made which would then become the defaults the next time I move through them, i.e. I may not see what you're seeing and vice versa. Good luck!
     
  15. macrumors member

    Joined:
    Jun 12, 2009
    #15
    when you get into ATV via SSH go to:

    -private/var/mobile

    Drop the unzipped filed into

    -private/var/mobile/Media

    Go to XBMC

    Locate the "install via .zip" option under settings-addons
    I had to navigate backward on the addons menu a few steps to find the "install via .zip" option.
    Once i did, Navigated to the .zip. Selected it and it will say enabled.

    Turn off XBMC and re-open it. I didnt see any of the new add-on's til I re-booted XBMC.

    hope this helps. Loving the South Park Studios add-on!
    :]
     
  16. macrumors 6502

    Joined:
    Jul 14, 2008
    #16
    So I did both of these and still dont see the hulu+ add in or any new add its. I went into the install via zip file select the bluecop repository file, clicked ok, rebooted the xmbc and still no luck. I must be doing something wrong. I am an idiot. Sorry to be a pest.
     
  17. macrumors 6502

    Joined:
    Jul 14, 2008
    #17
    OK. I tried this again and no luck. I moved the file into the media directory, went to video add ons, select "install from a zip file", navigated the directory tree to the file, highlighted the file and selected the middle button on the remote, or aka the enter button, and it went back to the previous menu for video add ons. Powered down the entire apple tv and went back into xbmc, selected video, browse add ons, and do not see any of the bluecop add ons, just the basic ones with xbmc. I am not sure what I am doing wrong. The file size for the repository is 666B. Any ideas?
     
  18. macrumors member

    Joined:
    Jul 5, 2010
    #18
    Having the exact same problems as the OP- SSH'd the files over, enabled the add ons, but can't enable the skin / bluecop
     
  19. macrumors regular

    Joined:
    Aug 18, 2010
    #19
    Let me provide a pic to help if you don't mind after your instructions #5.

    Add-On Information (for example, click/tap “Install” for PBS)

    [​IMG]
     
  20. macrumors member

    Joined:
    Jun 12, 2009
    #20
    Do you have the right .zip?

    http://code.google.com/p/bluecop-xbmc-repo/downloads/list

    That is the one I used. Once i selected it it said in the bottom right corner "enabled" or "installed" or something of that sort. The main issue is putting the .zip in the right folder. After you click on it, restart XBMC and re-open it. Don't restart your ATV. That's what worked for me. But who knows, maybe I'm just lucky!

    Good luck! Hope you get it working! Its the jam!
     
  21. macrumors member

    Joined:
    Jun 12, 2009
    #21
    I realized I put to drop the unzipped file into the /mobile/media folder. That is not correct. Just drop the plain .zip file there. Don't unzip/unarchive it. Just download/drop. Hopefully this is the advice you were needing!
     
  22. macrumors 6502

    Joined:
    Jul 14, 2008
    #22
    I just used the plain zip file the entire time. Still no luck. Will try again.
     
  23. macrumors regular

    Joined:
    Aug 18, 2010
    #23
    To cmhsam,

    You mentioned you're using a mac for cyberduck.

    When you download the bluecop repo zipped file, did you do a RIGHT-click and choose 'download linked file'?? ...this will keep the file zipped.

    If you click the zipped file directly, that's the problem...it's automatically unzipped if you click the zipped file directly.
     
  24. macrumors 6502

    Joined:
    Jul 14, 2008
    #24
    Let me try that...
     
  25. macrumors 6502

    Joined:
    Jul 14, 2008
    #25
    When I right click and select download linked file it just downloads the .html file.
     

Share This Page