White lines through iPod Nano screen?

Discussion in 'iPod' started by skubish, Jun 24, 2006.

  1. skubish macrumors 68030

    skubish

    Joined:
    Feb 2, 2005
    Location:
    Ann Arbor, Michigan
    #1
    My iPod nano has suddenly developed a 1/4 inch white band across the middle of the screen. I tried the 5Rs with no luck. Anyone know of a fix for this or is it busted. It is a year old so it is out of warranty.

    If it is busted, its pretty lame my 3G 20GB iPod laster longer than the nano.
     
  2. SamJ macrumors member

    Joined:
    Mar 10, 2006
    #2
    dude, the same thing happened to my 5g 30GB yesterday. My ipod was perfect apart from a few back scratches, the screen was immaculate to say the least. So I listen to it yesterday..turn it off... turn it on again and I've got this digital tearing in the screen. Its like pixel distortion. I've had mine for a month so I'm gonna power the battery down and recharge, if it doesnt work Im claiming repairs on it.

    If its over a year old, I would suggest just letting it sit. Stupid I know, but I did it to mine and the screen somewhat resored. It still got this ugly pixel band running down the screen of white lines. Honestly just put it down for a few days. Yours might not be as bad as mine and could therefore magically heal.

    Good Luck:)
     
  3. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #3
    Maybe its just a scratch?

    If not, try restoring iPod.
     

Share This Page