Who got a lemon 3G? Who got a perfect one?

Discussion in 'iPhone' started by cyberone, Jul 16, 2008.

  1. macrumors regular

    Joined:
    Oct 24, 2005
    #1
    Scary reports about dead pixels, dust under the screen and cheap finishings ...

    The majority out there has no issues?
     
  2. macrumors 6502

    Joined:
    Apr 15, 2006
  3. macrumors regular

    Joined:
    Apr 24, 2008
    #3
    mine its perfect!:D
    except for the slow 3G speeds :(
     
  4. macrumors 6502

    Joined:
    Jun 28, 2007
    #4
    I received a lemon on Friday, wouldn't connect to the network for ****, sim was replaced, etc, etc, etc.

    Got mine replaced on the spot, and now its perfect ;)
     
  5. macrumors member

    Joined:
    Jul 2, 2008
  6. macrumors newbie

    Joined:
    Jul 15, 2008
    #6
    I have a lemon one,

    Dust under the screen, marks on the edges and light beams out between the glass & the chrome!!!! :mad:
     
  7. macrumors regular

    Joined:
    Jul 11, 2007
    #7
    Mine's perfect :) 8GB black. And teh 3G speeds is amazingly fast.. 3,6mbit/s almost wherever I am in my city.
     
  8. macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
  9. macrumors regular

    Joined:
    Jul 8, 2008
    #9
    I had a lemon, non-working speaker and headphone jack. Returned for a new one.
     
  10. macrumors 65816

    Joined:
    Feb 22, 2007
    Location:
    Southampton UK
    #10
    Fingers crossed mine seems absolutely fine, I only got it a few hours ago though so who know what might happen.
    If theres a hint of dust under the screen the thing is going back.. (how the hell would it even get in?!).
     
  11. macrumors newbie

    Joined:
    Jun 25, 2008
    Location:
    Buffalo
    #11
    lemon...My ringer switch broke right off when I tried to switch it to vibrate...returned it, got a brand new one, its perfect now.
     
  12. macrumors newbie

    Joined:
    Oct 14, 2006
    #12
    Perfect here. No scratches, no smudges under the screen, no cracks, no technical issues, and no loose switches.

    (16GB White)
     
  13. macrumors regular

    Joined:
    Mar 3, 2008
    Location:
    London
    #13
    Picked my black 16gig up on Monday and all looks and works well .. very impressed so far. Just wish there weren't so many goodies in the app store, I need a 32gig :D
     
  14. macrumors regular

    Joined:
    Jul 11, 2008
  15. macrumors member

    Joined:
    Jan 24, 2008
    #15
    Worked perfect

    Mine has been working great since Friday 12pm :D

    Black 16 GB
     
  16. macrumors regular

    PDACPA

    Joined:
    Jul 16, 2008
    Location:
    Florida
    #16
    Mine was DOA. Screen would not respond, but you could hear it ring. I was in the Apple store, but had to go through an entire return at the Genius bar since the sim had been activated.

    New one is working fine.
     
  17. WHM
    macrumors regular

    Joined:
    Feb 5, 2008
    Location:
    South
    #17
    PERFECT..... 16Gb Black..... had the original and thought that was awesome.... this one is unbelievable. Really fast 3 G.....
     
  18. macrumors member

    Joined:
    Aug 22, 2004
    #18
    I have a lemon, rattles when on vibrate, i'll return it next week some time for a replacement.
     
  19. macrumors 6502a

    gcmexico

    Joined:
    Dec 22, 2007
    Location:
    New York City
    #19
    weird situation here

    the first one I got 8gb black, kept on stalling when I would go to contacts...it would freeze a good 10 secs before I could scroll...I thought it was defective, my 1st generation never stalled on me...took it back got a new one, but same problem, but it only stalls 3 secs now...anyone else having this issue, when you switch to contacts, it takes a couple of seconds to be able to scroll, it's very annoying, maybe it's a bug on all fons?:(
     
  20. macrumors member

    Joined:
    Jul 14, 2008
    Location:
    Los Angeles, CA
  21. macrumors 65816

    PoitNarf

    Joined:
    May 28, 2007
    Location:
    Northern NJ
    #21
    First one died after 36 hours, got "Repair needed, unable to make or receive phone calls" error message on the phone and after that it pretty much quit working. Was unable to restore the software on it.

    Got a replacement at the Apple store just 2 days ago and it's been chugging along fine so far...
     
  22. macrumors newbie

    Joined:
    Jul 16, 2008
    #22
    I got a 16GB Black, working beautifully.

    Roommate also got a 16GB Black but his has had much worse battery life and has a group of dim pixels in the middle of the screen

    I was 5th in line, he was 6th. Phew.
     
  23. macrumors 6502a

    Joined:
    Apr 11, 2007
    Location:
    Rocklin, CA
  24. macrumors member

    carlitol

    Joined:
    Jun 3, 2008
    #24
    My 16GB was acting sluggish when SMS and a few other things. Called Apple and had to re-install the software and new firm ware. Works great so far. Don't forget to sinc your contacts and calender with outlook if you are on a PC before you try it though.
     
  25. macrumors member

    Joined:
    Jul 2, 2008
    #25
    There's something wrong with my speaker that makes incoming voices, rings, etc., sound rattley and distorted when I'm on my talking phone. I'm hoping to swap it out this weekend.

    Otherwise, it's wonderful, and my husband's is perfect.
     

Share This Page