Why are my Page Down kes not working in Safari?

Discussion in 'macOS' started by jive, Jan 9, 2007.

  1. jive macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #1
    On an iMac. They work in Text Edit and FireFox. What's going on?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Have you restarted? Do the regular arrow keys work? Have you tried restoring the default keyboard shortcuts in the Keyboard & Mouse pane of System Preferences? :)
     
  3. jive thread starter macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #3
    I have restarted both my mac and Safari, all shortcuts are defaulted. What can I do?
     
  4. Hobofuzz macrumors regular

    Joined:
    Oct 9, 2006
    #4
    Pushing the space bar also does page down in Safari.
    Shift+Space does a page up.
     
  5. emptyCup macrumors 65816

    emptyCup

    Joined:
    Jan 5, 2005
    #5
    I have noticed that on some sites I have to click on the page before Home and End work. I don't know why this is so but you could give it a try. Do the Page keys not work anywhere in Safari?
     
  6. jive thread starter macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #6
    Nope, not working on any sites or even in text files if I open them in Safari - it's a Safari problem - anyway of reinstalling Safari?
     
  7. jive thread starter macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #7
    K ,it's still doing it... It's really annoying, how do I reinstall from the disk?
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Well, Pacifist should allow you to reinstall Safari from the OSX discs. Alternatively, you could reinstall the latest combo update for your machine. Depending on what sort of iMac you have and what OS you're running, I can provide you with a link. :)
     
  9. jive thread starter macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #9
    I have now updated to 10.4.9 and reinstalled safari... It's still not working for me. It did for a few seconds then died. I really want to use Safari, I prefer the way it handles pages and text.
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    Did you use a combo update or simply the standard Software Update (delta) version? :)
     
  11. jive thread starter macrumors 6502a

    Joined:
    Apr 14, 2006
    Location:
    Scotland
    #11
    I did it through the Software Update bit... Cheers for the help :]
     
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia

Share This Page