Why can't my new MacBook connect to WPA-PSK wireless?

Discussion in 'MacBook Pro' started by tekhna, Jan 11, 2007.

  1. macrumors newbie

    Joined:
    Jan 10, 2007
    #1
    Airport sucks. A lot. It works just fine in WEP or unprotected networks, but WPA-PSK it doesn't do a damn thing. It shows it as connected with a full signal, but Safari, iChat, etc... won't connect to the internet. For some reason Azureus works, but it's going at an amazing 146 bytes/sec and then back down to 0. What's going on here guys? This is my first Mac and I am sorely disappointed in Airport.
     
  2. macrumors regular

    Paul Wright

    Joined:
    Aug 24, 2006
    Location:
    Germany
    #2
    i had the same problem took it to the store and kindly replaced the airport card :)
     
  3. macrumors 604

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #3
    It does sound like a hardware issue since my PowerBook connects to WPA-PSK protected networks no problem.
     
  4. macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #4
    I use WPA/WPA2 with my Airport Extreme (g) and MBP CD. No trouble whatsoever.

    Do you have access to a different router that you could try?
     
  5. macrumors 6502a

    Joined:
    Oct 7, 2003
    Location:
    London
    #5
    k

    i doubt its hardware as it connects to other types of connections fine !!!

    so it must be software ! think people

    got the same problem on my macbook pro still no fix wake up apple and yes iv got the latest wireless patch !!!!

    anyways have a word with apple but i guess you're in the same boat as me just a waiting game now i suppose
     
  6. macrumors newbie

    Joined:
    Nov 21, 2003
    #6
    the problem is that wpa-psk can use tkip or aes .. and I found that macs only work with tkip...

    try changing the encryption to tkip in the base station
     
  7. macrumors 6502

    cyberddot

    Joined:
    Jul 4, 2003
    Location:
    in a forest
    #7
    Just a quick snipit from the Airport Admin Utility help files:

    "WPA and WPA2 have two modes: Enterprise mode, which uses a RADIUS server for user authentication, and Personal mode, which relies on the capabilities of Temporal Key Integrity Protocol (TKIP) for WPA, and AES-CCMP for WPA2..."<snip>

    These help files actually have a small amount of helpful information.
     
  8. macrumors newbie

    Joined:
    Jan 15, 2007
    Location:
    Milano
    #8
    I have a similar problem with my MBP 17" C2D..It won't connect to my WPA-PSK network.
    I don't think is an HW problem cause the MBP connects to WEP or unprotected network without any trouble.

    IMHO is a software compatibility problem between my USR 9110 router and the Airport card.
     
  9. macrumors newbie

    Joined:
    Aug 10, 2007
    #9
    creat new location did it for me!

    I wasted 6 hours of my life with this same issue. what fixed it for me was to create a new location. hope this helps someone and that apple gets their stuff together!!!
     
  10. macrumors member

    Joined:
    Nov 1, 2004
    Location:
    SiNy
    #10
    mine has no problem connecting to WPA-PSK, but it does tend to drop due to 10.4.10, so i reverted back and everything is fine now.
     
  11. macrumors newbie

    Joined:
    Oct 3, 2008
    #11
    Hi, I'm having similar problem.
    Brand new Mac Pro, trying to connect to my WAP-PSK and after adding the KEY (As password) it says that password is wrong. Of course I checked 10000 times that the password is correcnt, the MAC address is in the router access list.

    It did connect first time around when I UNprotected the network so the the MAC PRO could see it in the initial setup screens. Then I added th MAC address, added protection, key to MAC and everything was fine for about one hour.

    Then after a re-boot the problem about not being able to connect started

    Any idea? What do you mean creating a new location?

    Cheers
     
  12. macrumors newbie

    Joined:
    Dec 12, 2010
    #12
    May need to toggle SSID

    I ran into the same problem with my MacBook Pro. I don't broadcast my SSID, but when I enabled it, the MacBook connected. I then turned my SSID back to being off and the MacBook continued to be able to access the connection.
     
  13. macrumors newbie

    Joined:
    Apr 15, 2012
    #13
    Click the  apple icon on the top-left of your Mac, open System Preferences then Network then Wi-fi
    on the bottom-right you can see the Advanced... button, just click it. on the first tab "Wi-Fi" Click the plus button;

    Network Name: Your wifi SSID Name
    Security: Any (Personal)
    Password: Your wifi password

    just click OK.
    then another ok, maybe you need input your Mac Password to apply the change.Now your Mac will auto join your wifi.
    That's all!

    [​IMG]
     
  14. macrumors 6502

    Joined:
    Feb 28, 2011
    #14
    And you're absolutely sure that the capitalization of the passwords is correct?
     

Share This Page