why does my screen dim after 5 minutes

Discussion in 'Mac Pro' started by bdugan, May 9, 2006.

  1. bdugan macrumors regular

    Joined:
    Feb 14, 2006
    #1
    my mbp screen dims when not in use for about five minutes. I dont know why it does this or how to fix this. Its annoying when reading something online. Does anyone know how to change this? Thanks
     
  2. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #2
    Try System Preferences... (below the apple on the upper left)->Energy Saver. then adjust the "Put display to sleep..." option.
     
  3. galstaph macrumors 6502a

    galstaph

    Joined:
    Jul 24, 2002
    Location:
    The Great White North Eh
    #3
    does it light back up when you move on the trackpad, or press a key?
    if so it is probably an autodimmer. My ibook does this and the setting is in the energy saver panel in system preferences
     
  4. Fleetwood Mac macrumors 65816

    Fleetwood Mac

    Joined:
    Apr 27, 2006
    Location:
    Canada
    #4
    Its a feature on all mac notebooks to try and conserve battery life. Its real helpful IMO. It can extend battery life quite a bit.
     
  5. dmw007 macrumors G4

    dmw007

    Joined:
    May 26, 2005
    Location:
    Working for MI-6
    #5
    I agree- it is a nice feature. :)
     
  6. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #6
    I don't mind the feature when running on battery, but it's annoying as hell when I'm plugged in. I wish there was a way to disable it
     
  7. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #7
    This can also help prolong the life of the display's backlight, even if only a little bit. That's usually the first thing to go, although they do last a while anyway.
     
  8. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #8
    There is. Go to the Energy Saver panel, select "Settings for: Power Adapter", then tell it to never sleep the display.
     
  9. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #9
    Except that doesn't work :(
     
  10. kretzy macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #10
    You're right, it doesn't. I've been experiencing the same problem. I believe it started after the last OS update. I might be wrong though.
     
  11. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #11
    Really? Odd. It seems to listen to my settings, but I have it set at 30 minutes or something, not "never", and it seems to work OK (I don't time it, but it never blanks on me unless I've walked a way for a bit).

    Edit: haven't checked it recently... maybe the last update did screw it up. But it used to work.
     
  12. mikehowett macrumors member

    Joined:
    Apr 15, 2006
    Location:
    UK
    #12
    Energy Saver, Other Options:

    Uncheck; "Automatically reduce the brightness of the display before sleep" option, I think that should do it :)

    EDIT: Just tried it with my PowerBook and no dimming even after 10 mins:)
     
  13. zign macrumors 6502

    zign

    Joined:
    Apr 9, 2006
    Location:
    London
    #13
    Doesn't work for my or my girlfriends mbp. Weird.
     
  14. SC68Cal macrumors 68000

    Joined:
    Feb 23, 2006
    #14
    It's interesting how the Mac notebooks use the backlight energy saver strategies, while wintel laptops used speedstep technology.
     
  15. mmmcheese macrumors 6502a

    mmmcheese

    Joined:
    Feb 17, 2006
    #15
    I have mine set to never (while on power adaptor), and it stays on. I have done all the software updates.

    That probably doesn't help, but it does actually work.
     
  16. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #16
    Macs have that too. (Or at least something similar)
     
  17. skillz1318 macrumors regular

    Joined:
    Mar 21, 2006
    #17
    i have similiar problems i checked the box so it doesnt dim display before sleep and its set at 30 minutes...it used to stay full brightness then shut off display at 30 min, i dont know if it was the update or not, but the settings havent changed and it dims after 5 minutes, then shuts off after 30 min...doesnt really bother me since it comes right on after i move the mouse, but it seems like it could be a problem with the software...will test later to see if i have it never sleep display if that matters
     

Share This Page