Why is my Pbook buzzing when it charges?

Discussion in 'Mac Pro' started by Daedalus256, Jan 5, 2006.

  1. Daedalus256 macrumors 6502

    Joined:
    Nov 7, 2005
    Location:
    Pittsburgh, PA
    #1
    I just noticed this last night but, whenever my powerbook is plugged into it's P-P-P-POWERBRICK, I hear a very faint buzzing sound. It immediately stops once it's running on battery power. Is this thing going bad? Is this a known issue? If this thing is dying I think I'm going to need someone to kick in the teeth.
     
  2. Daedalus256 thread starter macrumors 6502

    Joined:
    Nov 7, 2005
    Location:
    Pittsburgh, PA
    #2
    I've actually like triple checked with guys at the apple store about my battery and it isn't part of the recall batch.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    It's all the electrons running from the wall into your PowerBook. I wouldn't worry about it too much. Have you just noticed it or has it suddenly got worse?
     
  4. Spectrum macrumors 6502a

    Spectrum

    Joined:
    Mar 23, 2005
    Location:
    UK
    #4
    What happens if you take out the battery (while it's plugged in, obviously) ?

     
  5. Daedalus256 thread starter macrumors 6502

    Joined:
    Nov 7, 2005
    Location:
    Pittsburgh, PA
    #5
    When I take it out, I still hear it.

    Also, and I remember a thread on this a while back, it just started sounding like a lightsaber when I move it.
     
  6. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #6
    My 17" PowerBook has been buzzing ever since I got it back in August of 2005. It only does it with the AC Adapter plugged in. I think its access noise coming through the speakers. Its not a big deal to me and my PowerBook works fine and has been ever since I got it. So I wouldn't worry about the noise.
     
  7. Nspace macrumors regular

    Joined:
    Jul 13, 2004
    Location:
    Toronto, Canada
    #7
    My 15" makes a bit of a high pitched buzz when the cpu performance is set to high in the preferences. Check that, perhaps its going to a lower performance setting when its on batteries. I would plug it in and try change the setting to see if you still hear it.

    Of course I could be refering to a totally different sound all together but its worth a try.
     

Share This Page