Why the hell does my iPhone 4 say "No Service" all of a sudden?

Discussion in 'iPhone' started by HXGuy, Sep 9, 2010.

  1. macrumors 68000

    Joined:
    Mar 25, 2010
    #1
    Man I want to throw this thing against the wall sometimes...

    All of a sudden, it's saying "Searching..." and then "No Service". I have a MicroCell 3G which has been working fine, plus my wife's iPhone 3G is working just fine in the same house (over MicroCell).

    I tried restarting the phone and also resetting the network settings. No luck.

    The phone is jailbroken/unlocked.
     
  2. macrumors member

    Joined:
    Feb 10, 2010
    #2
    Restore as a new phone and see if it works. Seems pretty straight forward to me.
     
  3. thread starter macrumors 68000

    Joined:
    Mar 25, 2010
    #3
    It was the stupid MicroCell. I unplugged it and it fixed the problem immediately. Damn what a waste of $150 that was.
     
  4. macrumors newbie

    Joined:
    Nov 18, 2011
    #4
    No service!!!

    I have iPhone 4, it was working just fine..no I have a problem: it keeps searching for the network and then says no network..it was open to clean from inside..how can I fix the problem?
     
  5. macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #5
    God hates you. :p
     
  6. macrumors demi-god

    Joined:
    Apr 20, 2009
    Location:
    NY
    #6
    Take it back to the guy that worked on it. :confused:
     
  7. macrumors newbie

    Joined:
    Nov 18, 2011
    #7
    And tell him what?? The signal keeps appearing and disappearing..please help me on this issue
     
  8. macrumors member

    Joined:
    Mar 8, 2011
    #8
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    How u unlocked it?
     
  9. macrumors newbie

    Joined:
    Nov 18, 2011
  10. macrumors 6502

    Joined:
    Oct 9, 2011
    #10
    This happened to my iPhone3G after i dropped it.

    the sim card slot got loose and wasn't touching the contact pins. If i squeeze the case a bit and turn airplane mode on/off it gets signal again.

    this might be your problem, but there other various causes.
     
  11. macrumors newbie

    Joined:
    Nov 6, 2011
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Does it say no service when you Are not holding it? I noticed that when i am hOlding my iphone 4s in my left hand,and my thumb and or hand are covering the bottom left antenna i lose reception rather quickly,and then when i move my finger or hOld the phone differently i have no problems...i thought they said they solved antenna gate??? :(:(:(
     
  12. macrumors 6502

    Joined:
    Oct 9, 2011
    #12
    iphone4S has two antenna one at the top and bottom. It switches back and forth depending on which is stronger or how u hold.

    are you in an area where your reception is shaky to begin with like 0-1bars? Not that the bars is a poor representation of actual signal strength. It is just there to simplify it for most consumers.
     
  13. macrumors 65816

    Joined:
    Aug 10, 2010
    #13
    Because it doesn't have service...... not THAT hard to figure out.

    What did you spend $150 on? I got my MC for free..... don't even use it.
     

Share This Page