Why won't Safari remember full-screen setting

Discussion in 'Mac OS X Lion (10.7)' started by Mikegs, Aug 3, 2011.

  1. Mikegs
    Expand Collapse
    macrumors regular

    Joined:
    Aug 6, 2010
    #1
    I wan't to use Safari in full screen. However when i close or quit safari, it goes to normal mode when re-opened.

    Other apps stay in full-screen unless manually changed
     
  2. BlackMangoTree
    Expand Collapse
    macrumors 6502a

    Joined:
    Sep 30, 2010
    #2
    Can't be of any help sorry but it's driving me insane. Hopefully Apple fix it in the next update.
     
  3. abta1
    Expand Collapse
    macrumors 6502

    Joined:
    Jul 5, 2010
    Location:
    Paris, France
    #3
    This doesn't happen to me, when I close safari using cmd + Q and reopen, it automatically goes into full screen mode.
     
  4. stuartmack1974
    Expand Collapse
    macrumors member

    Joined:
    May 9, 2011
    Location:
    swansea, wales, uk
    #4
    What would also be a nice add on is remembering your preferred text size, so that when i hit the macrumours site, resize the text an dclick on a thread it stays at that size !!!!:mad:
     
  5. Mikegs
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Aug 6, 2010
    #5
    That's strange. Anyone have ideas as to why Safari reopens as fullscreen in some but not others systems? Closing Safari by command-Q or command-W makes it reopen non-full screen in my system
     
  6. NewYorkRanger
    Expand Collapse
    macrumors regular

    NewYorkRanger

    Joined:
    Oct 27, 2010
    #6
    I'm having the same problem.

    Only way I can get it to stay full screen is if I check off "reopen windows when I login" when I log off my system, and that is if I leave Safari open when I log off.

    Otherwise, anytime I launch it, it doesn't open in full screen, just in a window.

    I recently re-installed Lion, this never happened before.
     
  7. wennydi
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 28, 2008
    #7
    open System Preferences > General, and deactivate "Close windows when quitting an application"
     
  8. machoflaco
    Expand Collapse
    macrumors newbie

    Joined:
    Aug 3, 2013
    #8
    THANKS SO MUCH. This finally fixed the problem for me!
     
  9. jtemelko
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 1, 2015
    #9
    Yes, the deactivation of "Close windows when quitting an application" works in terms of re-opening Safari in full-screen mode but the annoying thing it opens on the last page you were browsing instead of your home page so it's not a 100% fix. C'mon Apple, you need to do better than that.

    Incidentally, I only switched to Mac OSx from Windows after they finally made a "Full Screen" button. That took many many years for a simple feature!
     
  10. anp27
    Expand Collapse
    macrumors regular

    Joined:
    Jan 17, 2011
    Location:
    Brooklyn, NY
    #10
    This solved it for me too, thanks! I'm actually on El Capitan 10.1.13 right now.
     
  11. jtemelko
    Expand Collapse
    macrumors newbie

    Joined:
    Nov 1, 2015
    #11
    It will only open whatever your last window was but if you close this window before quitting it will open your home page in a small window only and not in full screen. There is no true way to make it open in full screen by default.
     

Share This Page