Why wont this YouTube video play?

Discussion in 'iPod touch' started by dporter, Jun 9, 2011.

  1. macrumors newbie

    Apr 14, 2009
    I've done a lot of searching and cannot find a definitive answer as to why some YouTube videos won't play on my iPod Touch 4g. For example:


    clicking that link opens up the YouTube app but the video dies not play. I get a "Could not load movie" message.

    I get this error more often than I would like. These are short videos usually around 3 minutes, have been uploaded for some time, and happens with about 20% of the videos I try to play.

    Does the video play for you on your iPod / iPad? Do you have a workaround for when this happens?
  2. macrumors member

    Mar 8, 2009
    Hey - Most of the time its due to the age of the video upload, this one for example was done back in 2009 which was 2 years ago now. YouTube as you know relies heavily on Flash for video playback which is not compatible with the iOS range.

    However to combat this, YouTube did work on converting chunks of videos to H264 playback, but by default the entire backlog of videos did not go through this conversion process...so you will find the odd video out there that does not play.

    I believe though (and please someone correct me here if i am wrong) YouTube by default now encodes uploads in H264 as well as flash and a few other formats for multi-platform enjoyment :)


  3. thread starter macrumors newbie

    Apr 14, 2009
    Thank you very much for that great reply.

  4. macrumors G5


    Jun 27, 2007
    YouTube user has to turn on syndication option to be encoded for mobiles.
  5. macrumors 65816


    Jul 29, 2010
    Edmonton, Alberta, Canada
    Especially copyright identified videos.

Share This Page