Wifi changes in iOS7 GM

Discussion in 'iOS 7' started by jmmo20, Sep 11, 2013.

  1. macrumors 65816

    Jun 15, 2006
    So.. A few weeks ago I discussed how I found a "bug" in the wifi controller in iOS 7. Basically my phones with iOs7 would drop the wifi connection soon after you put the device to sleep.

    I reported this as a bug to Apple but they did nothing really, they didn't even reply to my report.

    This is specially annoying since at work, we have no cellular signal, only wifi, and the wifi requires authentification in a login page that always changes (so iOs cannot remember it either). Before, with iOS6, I had to log in once a day and the phone kept the wifi alive all day long. Now in iOS7, I basically have to log in every time I want to use my phone.

    I guess this is a new measure to "dramatically save battery".
    But for me it's rather annoying .. I wish there were apps to keep wifi alive (and if there are and I don't know, plase do let me know!!)

    So, rant over :)
  2. macrumors regular


    Jun 11, 2011
    Paris, France
    This happens to me in ios6. Although it's not all the time instantly when the device is put to sleep, if i'm on a wifi that needs to open a webpage for authentification, it will happen regularly because the wifi stops probably to save battery.

    Have you checked that "auto join" and "auto login" are activated when you go check the details of your wifi network?

    The real solution i found if i really need constant wifi availabe was to disable auto sleep on the iphone and let it unlocked - but this will drain your battery much faster of course
  3. macrumors 6502a

    Mar 4, 2013
  4. thread starter macrumors 65816

    Jun 15, 2006
    Probably iOS7 makes this more stringent (i.e. waits less time to drop the conection), because for me in iOS6 that wasnt an issue and now is.
  5. macrumors 6502a

    Mar 4, 2013
    Hmm to be honest i didnt try ios 7 beta, waiting for public release. So yeh maybe they changed it for more battery life because new features eats more battery, so they are trying to compensate it in other ways :/
  6. macrumors regular

    Jan 26, 2013
    AFAIK, in previous beta version when i put both my iPad and my iPhone to sleep the wifi signal remained.
  7. macrumors 6502


    Sep 10, 2013
    They didn't fix because. It not a bug, when its intentional design, intended behavior.

    My corporate network is the same, except they also offer a guest network with no authentication required. You need to convince IT to offer a guest network for personal devices segregating corporate data.
  8. thread starter macrumors 65816

    Jun 15, 2006
    how does it make sense to drop the only available connection? At least let me decide if I want to keep the connection alive!

    what you describe is what happens currently, the corporate wifi is for company laptops only, it does MAC filtering. Then there's a guest network where you have to log in. The problem is that the auto login feature of iOS is not smart enough to learn the sequence (how hard is it to memorise that you have to click an option button in addition to entering username and password?)

    Yes, at the end of the day it's my wifi's fault, and those "helpful2 IT guys, buyt hey, apple doesn't make it any easier either!
  9. macrumors 6502


    Sep 10, 2013
    Surely you have others using Apple devices at work. iPad's and iPhone's are very popular in the corporate environment. It can be changed.

    Our IT reworked the wifi network, caused a similar issue, internal email list lit up with complaints, I'm sure many filed officially through IT system, it lasted 3 days before IT reverted back to a system that didn't bonk devices in standby.
  10. thread starter macrumors 65816

    Jun 15, 2006
    I hope that next week as the number of users with iOS7 increases, so would the complaints. As I said, I think iOS7 made my problem worse, as with iOS6 I only had to login once or twice but now with 7 it's every time I put the phone to sleep.

    And the IT thing is rather complicated. This is a public research institution, part of the campus is rented to small companies, like the one I work for. We have an internal IT department that runs our cabled network and corportate Wifi independently of the campus IT infrastructure. The public Wifi that we have to use for the personal devices is run by the public campus though, so It's rather difficult to contact "any IT department" as they don't even have emails or telephone numbers. We have to go through the building administrators who have no idea of IT whatsoever and all they say is "well, it works in my laptop so it's fine".


    I just thought that I would run a VoIP app such as Skype.
    Surely SKype keeps a background daemon so you can receive calls right? well, I thought so, but not really, even with Skype running, soon after putting the iphone to sleep the wifi connection is dropped.

    How then, am I supposed to receve voip calls? I don't understand this.
  11. clintbeastwood, Sep 11, 2013
    Last edited: Sep 11, 2013

    macrumors newbie

    Aug 16, 2013
    I'm having the same exact problem as you OP. from what I've noticed is they have weakened the signal strength, I'm guessing to preserve battery life

    what I've also noticed though is the delay it takes to reconnect, even standing in the same room with the router I'll check my phone and it will take a couple of seconds for the wifi to reconnect

    not only that but when the phone is locked and the wifi is disconnected I'm not receiving any push notifications until it reconnects. now I know it did this in ios6 but it was never this bad

    I'm surprised not many others have been experiencing this or how it managed to slip through all of the betas

    edit: few other things I noticed. if you stream music off your phone or are on a skype call or even something such as leaving the flashlight on all while the screen is locked the wifi stays connected

    also it stays connected if you keep it charged constantly

    and I have no idea why people are saying he needs to convince his IT department to change their policies when this is clearly an apple issue, this needs to be fixed. I'm sure once it goes public it'll be one of the things fixed in 7.0.1
  12. macrumors 65816

    Dec 5, 2011
    Have you guys tried to enable wifi sync? When that was enabled (in iOS6), the router would maintain the connection even when the phone was in sleep mode. You would see the wifi signal meter briefly appear just after waking the device (like it does always) BUT if you were to watch the connections in the router, the connection was always there. If you disable wifi sync, the wifi signal meter on the phone behaves the same way however you can see the connections drop off in the router a few moments after the device was put to sleep. I assume iOS7 may function the same way. Cannot verify since iTunes 11.0.5 wont work with iOS7 and I cannot enable wifi sync.
  13. macrumors 6502a


    Sep 8, 2008
    Same issue here on iOS 7 GM on corporate Wifi with a login page. Had the same issue on iOS 6.
  14. thread starter macrumors 65816

    Jun 15, 2006
    the problem is that I don't sync my iphone at work
  15. macrumors 65816

    Dec 5, 2011
    Well that would not matter. If you have wifi sync enabled on the device it will most likely continue looking for its sync partner all the time. You can disable wifi sync and then look at it in work or home router and verify.
  16. thread starter macrumors 65816

    Jun 15, 2006
    but it's now enabled and wifi is dropped anyways..

Share This Page