Wifi won't connect automatically

Discussion in 'iPad Tips, Help and Troubleshooting' started by Choicy, Apr 10, 2012.

  1. macrumors newbie

    Joined:
    Apr 10, 2012
    Location:
    Atlanta, GA
    #1
    Hey guys! I recently bought my first iPad (3rd gen.) and I'm loving it so far but I have a small problem with the wifi. It won't connect automatically to my home network when I turn on wifi. My iPhone connects to known wifi networks automatically when I turn it on and even connects automatically when I go to a Starbucks. Is this normal for iPads and how do I fix this?

    Thanks for any advice!
     
  2. macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    No, you should connect automatically to your home network, most people recommend resetting your network settings on the iPad...Delete them and re enter the details.usually does the trick
     
  3. thread starter macrumors newbie

    Joined:
    Apr 10, 2012
    Location:
    Atlanta, GA
    #3
    How do I reset my network settings on the iPad?
     
  4. macrumors member

    Joined:
    Mar 6, 2008
    Location:
    Lancashire, UK
    #4
    Hi,

    I have the exact same problem with mine. Tried resetting network setting and all setting and it still the same....

    Just won't connect automatically, I have to type in my password every time I switch on wifi...

    Really annoying....

    Ian
     
  5. macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    If that's the case, then I'd take it back for a swap out, or at least get a genius to take a look...Mine connects first time every time without asking for passwords etc.
     
  6. macrumors member

    Joined:
    Mar 6, 2008
    Location:
    Lancashire, UK
    #6
    I seem to have fixed it purely by guessing....

    Try this....

    Go to wifi settings and switch on wifi.... You wireless name should appear but will not connect automatically.

    Now press the home button and press the safari button....

    It will instantly not work and a little box will appear with wireless connection available...

    Select yours and it will connect...

    Now go back to wifi setting under the general tab and switch off the wifi, switch it back on and it should connect automatically....

    Worth a try it work for me...

    Tanks

    Ian
     
  7. thread starter macrumors newbie

    Joined:
    Apr 10, 2012
    Location:
    Atlanta, GA
    #7
    That worked PERFECTLY! Thanks! :D
     
  8. macrumors member

    Joined:
    Mar 6, 2008
    Location:
    Lancashire, UK
    #8
    Glad it worked for you as well

    It was doing my head in as well...

    Thanks

    Ian
     
  9. TonyWatt, Apr 17, 2012
    Last edited: Apr 19, 2012

    macrumors newbie

    Joined:
    Mar 28, 2012
    Location:
    Dunfermline, Fife
    #9
    Hi, I've been getting the same problem. That didn't work for me. Did a Network reset, still no joy. I'm getting the 'fan', but every time I connect to my wifi, it lasts about a minute then disconnects. I've tried various 'fixes' all to no avail. Please help a guy in serious distress before I take a sledgehammer to my new iPad. Thanks in advance

    UPDATE - I've logged a call with Apple (UK) and they are going to phone me tonight at 18:00. I'll let you know how I get on. Spoke to the wife about this, and she said she was having problems with her laptop connecting to the internet. Alarm bells rang. Disconnected the router, re-connected and voila...everything back to how it should be. Call to Apple cancelled

    Lesson learned - Try the obvious solutions first......
     
  10. macrumors newbie

    Joined:
    Apr 21, 2012
    #10
    it should connect automatically. if it doesn't, usually what i do is turn off wifi and turn it back on, which will trigger it to find wifi again.
     
  11. macrumors 6502

    Joined:
    Mar 14, 2011
    #11
    @Tony, the iPad is at best only half of the story here. I've never had that happen to me. If the normal tricks are not fixing the issue, then I'd look at how your router is configured. Is your password only using 0 to 9, or a to z, or A to Z? How about the access point name?

    When I have WiFi issues, I always like to start at the basics and see if I can connect. Then slowly add things until I determine what is breaking it. Are you running current firmware on your router? Have you tried restarting (power cycling) the router/access point?
     
  12. macrumors newbie

    Joined:
    Dec 19, 2012
    #12
    Thank You

    Thank you for the advice, it solved my issue first time. So people know exactly what I did here it is again. For the record I have an iPad2.

    The problem was it would not auto connect like my iPhone does.

    1. Go to Wi-Fi and turn ON - all available networks will appear including yours but it will not connect (that is why you are here).

    2. Hit home button and return to main screen.

    3. Open safari and try to open a page.

    4. It will not open and a small box will appear with available networks. Select yours. It should connect and you are online.

    5. Return to Wi-Fi settings and select OFF. Then select ON and your iPad will find your network and connect automatically.

    6. Do this again and again just for fun to see it now works and feel joy overcome you like it did me.

    7. Go to pub and drink beer satisfied with your job now done.

    * Options 6 and 7 not required but I found them helpful.

    A big Thank You to Ian.C.

    Some of the worlds greatest problems have been solved by guesswork, great stuff fella. Cheers. Meet me in pub, beers on me!
     
  13. macrumors newbie

    Untethered

    Joined:
    Dec 23, 2012
    Location:
    Boston, Ma
    #13
    A Simple Way...

    Well, before I go answering your questions, I must inform you that I do have an iPad 3 myself, and have great knowledge of it. I have never came across this problem, but my friend has. The following few sentences might not be perfectly accurate, if so, please reply regarding my mistake.
    To fix this problem, simply go to network preferences, click Automatically join networks and enable it. (If already enabled, disable and then enable) After doing so, join your network of choice. Then click the blue circle next to it, and if not, click the button that makes it a known network.


    Best Regards,​

    Untethered​
     
  14. macrumors newbie

    Joined:
    Jun 4, 2013
    #14
    Ahh thanks! My dads was acting up and that fixed it!
     

Share This Page