Window not remembering icon arrangment.

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Wes, Apr 10, 2004.

  1. Wes macrumors 68020

    Wes

    Joined:
    Jun 22, 2001
    Location:
    London
    #1
    This pic will sum it up, I've gone to view options, told it to keep them arranged, which it does, until I reboot. Repaired permissions, I would run fsck -y but that's not need now that we have journaling, right?
     

    Attached Files:

    • pic.jpg
      pic.jpg
      File size:
      53.7 KB
      Views:
      60
  2. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #2
    journaling is not on by default unless u r running a server edition..you can turn it on by terminal by this command..
    'sudo diskutil enableJournal /'

    but i dont see how journaling has anything to do with your problem..

    you can try this,,make a back up of .DS_Store of your home directory...then delete .DS_Store..now change the view option..see if it sticks..if the problem continues, you can rename the backup as .DS_Store again..and our method failed..:eek:

    hope it helps
     
  3. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #3
    It sounds like you have a .DS_Store file that for some reason or other you don't have write permissions to. To find out, lets take a trip to your root directory with the Terminal!

    Open up a new Terminal window. You can find Terminal in the Utilities folder.

    At the prompt that appears, type the following:

    ls -ld /.DS_Store

    and hit enter. You should see a single line of output similar to this:

    Code:
    -rw-r--r--  1 esheep  admin  6148  2 Apr 17:42 /.DS_Store
    
    What you are looking for is what appears in the place of -rw-r--r--, in the place of esheep, and in the place of admin. These are the file permissions on your root directory's DS_Store file. Here's how they break down:

    - | rw- | r-- | r--

    • The first character, '-', indicates that this is a generic file we are looking at.
    • The next group of three characters are the read/write/execute permissions for the owner of this file/directory (more about the owner later). If an 'r', 'w', or 'x' appears, that means that permission is granted. If a '-' appears, that means that permission is denied. So, r-- means that one has read permission, but does not have write or execute permission.
    • The next group of three characters are the read/write/execute permissions for the group of this file/directory (more about the gruop later)
    • The next group of three characters are the read/write/execute permissions for everybody else

    The owner of the entry is whoever appears in the place of esheep. The owner is always an individual user, and generally has the most freedom over the entry.

    The group of the entry is whoever appears in the place of admin. Multiple users can be assigned to multiple groups. Everyone in the groups has the permissions granted to that group. This information is only really useful if you know what groups you belong to! To find that out, type the following in the terminal:

    groups myshortusername

    where myshortusername is the short form of your username. This is the same as the name of your home directory as it appears in the Users folder. So, if my home directory is /Users/esheep, my short user name should be esheep

    What you will get is a short list of all the groups you belong to. Try to remember this, or write it down somewhere.

    Going back to what you saw when you typed ls -ld /.DS_Store, start to consider:

    • Am I the owner of this? If I am, do I have write permissions?
    • If I am not the owner, am I a member of the assigned group? If I am, does that group have write permissions?
    • If I am not the owner, nor am I in the assigned group, do I still have write permissions as a member of 'everyone else'?

    If the answer to all three of these questions is 'No', then that right there explains why you cannot change the icon arrangement.

    To fix this, simply type the following in a terminal:

    sudo chown myshortusername:myshortusername /.DS_Store

    Where myshortusername is, once again, your short username. You will need to enter your password to confirm this operation. Don't worry, even if you mistype something, this is a pretty benign command.

    Next, to make sure you have read and write permissions on this file, type the following in a terminal:

    sudo chmod 0644 /.DS_Store

    Once again, you will need to enter your password to confirm this operation. It is also pretty benign, so don't worry about mistyping something.

    Do a last ls -ld /.DS_Store and check to see that you are now listed as the owner of this file, and you have read/write permission on it. You should now be able to change the icon arrangement and have it stick!
     
  4. Wes thread starter macrumors 68020

    Wes

    Joined:
    Jun 22, 2001
    Location:
    London
    #4
    Thanks very much for a post that you obviously spent time writing, it has fixed the problem. I didn't seem to be the owner of the file for some reason but that terminal trickery has done the job! Thanks a lot once again for the really good post.
     
  5. TyWahn macrumors 6502

    TyWahn

    Joined:
    Oct 25, 2003
    #5
    I have had the same problems .. but now I am getting an invalid arguement message ... after I type sudo chown myshortusername:myshortusername /.DS_Store
     
  6. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #6
    Probably because your Netinfo database doesn't have a group entry for your short user name.

    You can leave off the :myshortusername

    sudo chown myshortusername /.DS_Store

    Where myshortusername is your short user name.
     
  7. Elan0204 macrumors 65816

    Elan0204

    Joined:
    Apr 16, 2002
    Location:
    Chicago, IL
    #7
    I was also having this problem, and followed the advice in the terminal that you suggested ElectricSheep, however it does not appear to have worked properly. After typing sudo chown myshortusername:myshortusername /.DS_Store I was prompted for my password. This seems to have gone fine. Then I entered sudo chmod 0644 /.DS_Store, but was not prompted for a password. Then, when I typed ls -ld /.DS_Store again, I get a permission denied message. Here is a copy of my terminal window. <snip>

    edit: Well I got the problems from incorrectly inputting this command solved. The problem was the inclusion of a space between the / and the . in /.DS_Store. So anyone else following the advice in this thread watch out for that. For the details of what the inclusion of that space caused, check out this
    thread.
     
  8. Elan0204 macrumors 65816

    Elan0204

    Joined:
    Apr 16, 2002
    Location:
    Chicago, IL
    #8
    OK, it appears that this is pretty serious, as clicking on my desktop has caused it to disappear. Plus right clicking has been completely disabled except for in a few places. I think I should start another thread to make sure my problem gets seen.

    edit: Problem solved. Check this thread for details.
     
  9. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #9
    why /.DS_Store and not ~/.DS_Store?

    and as you'll see, Elan0204 put a space in there, so he chown'ed and chmod'ed both "/" and ".DS_Store"

    oops!
     

Share This Page