Windows drive won't mount

Discussion in 'Macintosh Computers' started by Daveway, Dec 23, 2004.

  1. macrumors 68040

    Daveway

    Joined:
    Jul 10, 2004
    Location:
    New Orleans / Lafayette, La
    #1
    i received a hard drive form a friend that he had used as his windows 98 boot drive. He said that he got an error saying that it could not find the OS, so i glady took it and planned to use it as an external for my mac. I have a usb-ide adapter that i use on my other drives fine. However, the drive will not mount. I'm pretty sure i've tried everything in panther to get it to mount. Its not the adapter because it works with my other drives. Any help is really appreciated. Thanks
     
  2. macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    Sounds like the drive may be dead, or needs re-partitioning. Does it show up in the disk utility, and have you tried re-partitioning it?
     
  3. thread starter macrumors 68040

    Daveway

    Joined:
    Jul 10, 2004
    Location:
    New Orleans / Lafayette, La
    #3
    I odnt think it's dead. I hear it sppin and when it moves the head. I can't get it to show up anywhere. Is there an app. for OSX that can recognize any drive?
     
  4. macrumors regular

    kdawg

    Joined:
    Dec 14, 2004
    #4
    Um.. Just because a drive spins does not mean that it is working... the arm could have gone bad.
     
  5. macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #5
    Disk utility should show the drive, or display 'About this Mac' from the Apple menu, then choose 'More Info', then click on the USB entry and see if the drive shows up there. If it shows up but doesn't mount then try re-partitioning with Disk Utility. If it doesn't show up then I think it's dead.
     
  6. macrumors regular

    Joined:
    Dec 17, 2004
    Location:
    Omaha NE
    #6
    If the PC did not boot, possibly the PC didn't see it either. So the drive could be dead.
     
  7. macrumors newbie

    Joined:
    Sep 7, 2004
    #7
    It might not be dead. I was swapping (or attempting to) files with a Windows XP using friend through an external USB 2.0 hard drive. He plugged the computer into his Windows machine and it worked fine. When I plugged it into my powerbook (running os 10.3.7) nothing would happen. No mount, not in the hardware profiler or anything. When we plugged it back into the windows machine it worked just fine.

    Weird problem and we never figured it out. Think it was related to the formatting of the drive? Or the current alignment of the planets, who knows.

    Anyway, I suggest trying the drive on a Windows XP machine to see if it works on that. Then you would know if the drive is infact bad or not.

    hope that helps!

    -Steve
     
  8. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    In your case, it may just be that the drive was NTFS formatted and Mac OS X's "read-only" NTFS support isn't all it's cracked up to be. I would try the same thing stephenrydalch suggested. This will help isolate the cause of the problem (at this point it's most likely either Mac OS X not liking the drive or a dead drive).
     
  9. macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #9
    I Had a similar problem trying to get a 80 gig firewire drive to mount under osx 10.35.

    The solution in this case was to play about with the jumper settings on the drive. Osx eventually picked it up - The drive previously had Windows XP on it with FAT 32 and OSX disk utilitly just popped up and asked what I wanted to do with the new drive.

    If this does not work then, it may be that you need to remove the old Windows Fat 16 or 32 Partition. The easiest way to do this is to connect back up to a PC and use FDisk and just delete the Partition informatiion.
    Your friend should be able to do this for you if you do not have a PC.

    Connect then back upto ypur MAc and then switch on the OS should pick it up. (remember also you still may have to change the jumpers on the drive)

    :rolleyes:
     
  10. macrumors 68000

    Joined:
    May 10, 2004
    Location:
    Nottingham
    #10
    Nope. Windows 98 boot drive... do the sums, FAT32 only.

    Simie's suggestion might also be a shortcut to data loss; but then, you could only do that if the drive was picked up... visible.

    Which it isn't, right?

    If you have access to a Windows 2000/XP machine give it a go, these things happen, and as suggested you might want to mess around with jumper settings. But avoid using any apps which destroy data. You want to keep it intact... as suggested before Disk Utility will give a clue as to whether or not OS X can see it as an unformatted volume, and System profiler (USB bus) will let you know whether or not it's connected and alive.
     
  11. macrumors 6502

    davecuse

    Joined:
    Feb 20, 2004
    Location:
    NYC
    #11
    If you are planning on dumping all the info on the drive there are a few things you can try.. If this were mine, I would put the HD back in the windows box, and boot up with either a BartPE CD or a Knoppix CD depending on which environment you are more comfortable in. From here you can check to see if the drive shows up at all. If it does not show up in this scenario, boot to a DoD Erase CD (can't find the link at the moment) and zero out the drive. At this point put it back in the USB enclosure and format it using Disk Utility.

    If that doesn't do anything, you could either buy some type of windows friendly disk partitioning software to see if you're able to do anything (although I doubt you will be able to) or just scrap the drive and buy one that works and save yourself the aggrivation. I guess it all depends on how much free time you have. If you're like me at the moment, and don't have a job to go to, you might also want to check out SourceForge and see what else you can come up with at no cost.

    On a side note: if you're like me, you should probably be checking out Monster.com to find employment instead of sitting here fixing other people's problems... but I guess I'm just a nice guy
     
  12. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #12
    Uh...brap? I was referring to stephenrydalch's specific issue there, not daveway00's issue.
     
  13. macrumors 68000

    Joined:
    May 10, 2004
    Location:
    Nottingham
    #13
    Aah. See, to me it didn't sound like he still had any issues ;)
     

Share This Page