Windows IE issue

Discussion in 'Web Design and Development (archive)' started by mnkeybsness, Oct 15, 2003.

  1. macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Messages:
    2,511
    Location:
    Moneyapolis, Minnesota
    #1
    I know Rower will probably first tell me to make my site have valid html, and then include a link to the W3C site's validator...

    but other than that, Those of you that have access to a Windows machine can check with Internet Explorer and see that my site has a problem with my sliced image for the logo. The logo shows up correctly in every other browser that I've tried on every system...

    Browsers I've tested on and it has displayed correctly:
    • OS X - Camino
    • OS X - Mozilla
    • OS X - Mozilla Firebired
    • OS X - Opera
    • OS X - Internet Explorer
    • OS X - Safari
    • Windows - Mozilla
    • Windows - Mozilla Firebird
    • Linux - Mozilla
    • Linux - Mozilla Firebird
    • Solaris 9 (Unix) - Netscape

    PS: feel free to comment on the design, it's a major WORK IN PROGRESS though and I have a lot of rearranging in mind on my To-Do list.
     
  2. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Messages:
    11,111
    Location:
    San Diego, CA
    #2
    Ah, you know me so well. :)

    That said...it doesn't validate, but that's not the issue here. It's an IE whitespace bug. Whitespace gets added between elements when you've got whitespace in the code - why is anyone's guess. So, you just gotta remove the line breaks between the end of the mblogo1 image and the </td> as well as the one between the second <td> and mblogo2, like so:

    http://organicallydigital.com/mb/

    Now go validate your XHTML, and don't forget your CSS. ;)
     
  3. macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Messages:
    2,511
    Location:
    Moneyapolis, Minnesota
    #3
    Rower, thanks a bunch! i had two of my friends who know html much better than i telling me that there was nothing wrong.

    yeah... about that validating thing... i'll do it... ah... later


    and by later, i mean when i get time... and time is something i don't have
     
  4. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Messages:
    11,111
    Location:
    San Diego, CA
    #4
    You're quite welcome. It's an obscure thing that makes absolutely no sense...IOW, par for MS software. ;)

    And there's no time like the present to clean up invalid (X)HTML/CSS. It builds character...and chicks dig it...:p
     
  5. macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Messages:
    2,511
    Location:
    Moneyapolis, Minnesota
    #5
    i got news for ya... chicks don't give a rats...

    ha ha

    i'll get around to it this weekend possibly...

    maybe...

    :D
     
  6. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Messages:
    11,111
    Location:
    San Diego, CA
    #6
    Well then one of us is hanging around the wrong kind of chicks...oh wait...:eek:

    Keep me posted. :)
     
  7. macrumors 6502a

    FattyMembrane

    Joined:
    Apr 14, 2002
    Messages:
    944
    Location:
    bat country
    #7
    try tidy for cleaning up your html. there's no better safeguard than a valid page, that way if someone has a problem with the site, it's the browser, not your code. if you're working with xhtml, xml standards dictate that the browser shouldn't even display a page if there's a single error, although i'm somewhat thankful that browsers aren't this strict (yet) ;) .
     
  8. macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Messages:
    2,511
    Location:
    Moneyapolis, Minnesota
    #8
    Just thought I'd let you know that I've built some character and met some chicks now that I validated my HTML and XHTML pages... now if I do that CSS...

    I've got a question on validating the CSS... what the crap am I supposed to download? When I go to the validationg page, it gives me a huge list of stuff... and I'm too lazy to read into it... little help?
     
  9. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Messages:
    11,111
    Location:
    San Diego, CA
    #9
    As my good friend jelloshotsrule likes to say: noice!

    The easiest way is to make a favelet with the URL: http://jigsaw.w3.org/css-validator/check/referer

    That way, all you have to do is open your page in a browser, click the favelet and it goes straight to the validator.

    FYI, there are handy favelets for the HTML validator, too:
    PHP:
    javascript:void(document.location='http://validator.w3.org/check?uri='+document.location+'&charset=%28detect+automatically%29&verbose=1')
     
  10. macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Messages:
    2,511
    Location:
    Moneyapolis, Minnesota
    #10
    thanks rower....

    now let's see if i really get the chicks tomorrow.
     
  11. macrumors 6502a

    FattyMembrane

    Joined:
    Apr 14, 2002
    Messages:
    944
    Location:
    bat country
    #11
    the more web design i do, the more i come to hate IE (not that i don't hate it already). i'm working on a website for a local business and it works perfectly in safari/mozilla (it's completely xhtml1.1 and css2.1 valid) but of course, IE butchers it. i have two absolutely positioned div tags that are central to the layout; one if which is not displayed at all and the other is only about an eighth the size i've specified. the worst part is, i'm probably going to have to find some ass backwards way to jerry-rig the site so that it displays properly in IE (and more than likely break standards). i just had to vent.:D
     
  12. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Messages:
    11,111
    Location:
    San Diego, CA
    #12
    Post links if you want another pair of eyes or three to take a look at what's up.

    And I'm in complete agreement on IE's inability to conform to standards. I've got a design I'm working on that is pretty much perfect, less Opera/Mac losing bottom margin on my header and IE6/Win adding small gaps in the right border of my content section.

    http://larcdma.sdsu.edu/beta/

    Again, valid XHTML and CSS that IE doesn't want to handle the same way as everybody else.
     

Share This Page