Windows not going into standby because of keyboard driver

Discussion in 'Windows, Linux & Others on the Mac' started by millerrh, Mar 13, 2007.

  1. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #1
    While in windows, when I close my lid of my MacBook Pro (or try to go into standby via software) I get the following error:

    The device driver for the 'Terminal Server Keyboard Driver' device is preventing the machine from entering standby. Please close all applications and try again. If the problem persists, you may need to update the driver.

    Has anyone ever heard of this or know how to fix it?

    Thanks
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    As it turns out, though I don't have this problem myself, I know someone who does (on a Windows machine), and I'm stumped by it too... I believe the solution involves restarting Terminal Server, but I can find no way of doing this on Windows XP Home Edition (it's doable on Professional by going into the Service manager).
     
  3. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #3
    I've got XP Pro. Can you tell me how to do it? I have no idea what Service manager is. I don't see that in any of my applications.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    To get to the Service Manager, go to Control Panel (switch to Classic view if need be), click Administrative Tools, then Services. From here you can stop, start, and restart various Windows services, including Terminal Server.

    Once inside, right-click the service to modify and choose properties. There, you'll see a button to restart the service.
     
  5. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #5
    Hmmm...Can't find Terminal Server, but there is Terminal Services. Only problem is that the Restart command is grayed out so I can't restart it. I don't see anything in the list about a Keyboard driver or anything related to Apple.
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    That's normal - you should be seeing Terminal Services there. (I called it Terminal Server by mistake.) You also shouldn't see anything related to Apple there, unless you have iTunes for Windows installed - since that uses an iPod Service that will show up in that list.

    Anyway, since that doesn't seem to be working, try quitting or disabling stuff that makes use of Terminal Services - for example, Remote Desktop. The problem you're experiencing is (I believe) unrelated to Apple's drivers - it occurs because something is trying to use Terminal Services when your computer tries to go on standby.
     
  7. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #7
    Is there any way to determine what is using Terminal Services? I've never used Remote Desktop and have hardly anything installed on my computer...I have no idea what else could be trying to use it.
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    This is the point I have reached with the other person I know that has this problem, and it's got me stumped.

    I did a Google search, and found this... perhaps that can help isolate the cause of the problem.
     
  9. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #9
    Well I am stumped too. I disabled this service and restarted and I still get the error. Damn Microsoft....
     
  10. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #10
  11. Huyabusa1300 macrumors newbie

    Joined:
    Aug 17, 2008
    Location:
    Sarasota, FL
    #11
    A Fix for the TS Keyboard not allowing sleep issue.

    It's kinda funny to have to come into a Mac forum and fix a Windoze problem, But that's why everyone went out and got a Mac anywho!. Okay, here's the answer.

    The Fix
    Seen many posts with little help. To disable Terminal Server Keyboard Manager (A component of terminal services and also RDP) Right-click My Computer, select Manage. Choose Device Manager at the left tab and then click View>Show Hidden Devices. Then, select System Devices and DISABLE Terminal Server Keyboard Manager. DO NOT UNINSTALL IT!!! Also Disable Terminal Server Mouse Manager. Then, DO NOT REBOOT!!!!! Right-click My Computer, Select Properties, and at the Remote tab at the top of the window, UNCHECK the "Allow This Computer to send Remote Invitations. That should take care of the issue.

    Hope that's the end of all your troubles!
     
  12. kd5clr macrumors newbie

    Joined:
    Sep 22, 2012
    #12
    This does,t work

    :mad: If anyone reads this, DO NOT DO IT!! It will screw up your windows pc causing it to cycle on and off by itself. You will need to start on safe mode to re enable the TSK and MSK!


     

Share This Page