WinSCP: "Connection refused" ????

Discussion in 'iPod touch' started by eddyh, Oct 14, 2007.

  1. macrumors newbie

    Joined:
    Sep 18, 2007
    #1
    When I'm trying to acces my iPod touch with WinSCP
    I'm getting an Connection refused error.

    I'm using username: root and password: alpine

    I've jailbroken my iPod, I am connected to my own network. (And I even forwarded port 22 to my iPod..)

    I've done jailbreaking 3 times now, but the error is still there. (I restored before I jailbreaked again, ofcoure.)

    I'm using windows xp SP 2.

    What is wrong?
    Why am I getting that error?

    Thanks, Eddyh.
     
  2. macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #2
    Why are you not jailbreaking your touch on a Mac?


     
  3. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #3
    Because I've got a windows computer :rolleyes:

    But whats the point about that, it has to be possible on a windows computer too..
     
  4. macrumors regular

    Joined:
    Sep 30, 2007
    Location:
    Perth, Australia.
    #4
    Pure ignorance.

    Anyway, what firewalls do you have running? Try turning them off.
    Also, is it a Connection Refused error that says something about 15 seconds?
    If you continue to wait, after those 15 seconds - without pushing abort - it should log in after a while. It takes longer than 15 seconds sometimes.

    If that doesn't work, try CuteFTP 8. It's a much nicer FTP program.
     
  5. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #5
    I'm using zone alarm, but when I turned it off I got the same error.

    I'm getting an error that says: Error: Connection refused.
    Nothing about 15 seconds.

    I'm gonna try cuteFTP 8, thank for the tip.
     
  6. macrumors member

    Zeromus

    Joined:
    Sep 5, 2005
    #6
    Are you sure you aren't trying to FTP in instead of sftp-ing in? You have to make sure you select sftp.
     
  7. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #7
    Yes, it says Protocol: SFTP.
    I'm using the default setting of WinSCP, and still got that error.
     
  8. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #8
    CuteFTP 8...

    CuteFTP is not working either, I copied the error:

    Code:
    		*** CuteFTP 8.0 - build May 31 2007 ***
    
    STATUS:>  	[14-10-2007 14:41:54] Getting listing ""...
    STATUS:>  	[14-10-2007 14:41:54] Initializing SFTP21 module...
    STATUS:>  	[14-10-2007 14:41:54] Connecting to SFTP server... 192.168.0.XXX:22 (ip = 192.168.0.XXX)...
    ERROR:>   	[14-10-2007 14:41:56] The remote host actively refused the attempt to connect to it.
    		1) Verify that the destination server name or IP address is correct
    		2) Verify that the connection port number is correct (under Site Settings | Type tab).
    		3) The remote server may be temporarily or permanently inaccessible (try again later).
    		4) Verify that you have chosen the right protocol (SSH2, SSL, FTP, etc.) and have setup all required options for that protocol.
    		5) Verify that the destination IP address and port numbers are correct.
    		6) The remote server may be refusing multiple connections from the same client. Try using only one connection thread when connecting to this particular server (Site Settings | Options).
    		7) Try pinging the address.
    		8) If you are using a router, verify the router is up and running (check by pinging it and then ping an address outside of the router).
    		9) Do a traceroute to the destination to verify all routers along the connection path are operational.
    		10) Verify that your subnet mask is setup properly.
    		11) Verify that your local software or hardware firewall is not blocking outbound connections originating from CuteFTP.
    		12) Verify that your anti-virus software is not at fault (try disabling it).
    STATUS:>  	[14-10-2007 14:41:56] SFTP21 connection closed.
     
  9. macrumors regular

    Joined:
    Sep 30, 2007
    Location:
    Perth, Australia.
    #9
    Have you tried pinging the address with cmd prompt?

    run > cmd > ping ipaddress

    Haha, I don't mean to make you out to be an idiot, but make sure wireless is on on the Touch ;)
     
  10. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #10
    That is just working as it should work.

    Wifi is turned on :p
     
  11. macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #11
    Make sure you're opening an SFTP connection, not a regular FTP connection.
     
  12. macrumors newbie

    Joined:
    Sep 13, 2007
    #12
    I had the same problem

    Heya, I had the same problem, but I was able to fix it. What you need to do is install the community service pack? or something like that, look up "jailbreak making my battery die" or something to figure out which jailbreak package to install to fix that. When you do that, youll find out that OpenSSH is set to broadcasting sometimes, and so it is disabled. I think your SSH may be off, try turning it ON and you should be able to connect.

    This SSH thing http://www.iphonealley.com/tips-and...-life-after-installing-3rd-party-applications
     
  13. thread starter macrumors newbie

    Joined:
    Sep 18, 2007
    #13

    Well, that didn't work either, but I got some succes :D
    I installed another OpenSSH client from the Installer.app and that gave me acces to my touch!

    In that Services.app are 2 SHH things right now, but I don't care about that.

    Now, I got to find out how to install iPhone apps, but I'll find that out.

    Thanks for helping all,
    Eddyh.
     
  14. macrumors 65816

    Joined:
    Aug 21, 2008
    Location:
    Portsmouth, UK
    #14
  15. macrumors newbie

    Joined:
    Aug 31, 2011
    #15
    what SSH app did you download?

    I'm having the same problem, iphone4 ios 4.2.1 jailbroken, please help!

    I can't get SSH access into my iphone, connection refused. NOT firewall/antivirus problem.

    What SSH app did you download?? Pls help - need to make this work!
     

Share This Page