Wireless auto-connect to network and losing connection on sleep/fast user switching

Discussion in 'General Mac Discussion' started by frez, Jan 18, 2005.

  1. frez macrumors member

    Jan 12, 2005
    Hi there,

    I'm new to OSX and would appreciate some help with a Wireless issue.

    I have a new (one day old) PB 15" and I immediately updated to 10.3.7 first thing.

    How do I get my machine to automatically connect to my Wireless (Linksys Router based) network? In the Aiport Network settings, I have set:

    "By default, join: A specified network"

    My router is broadcasting it's SSID and it shows up correctly in my list of networks when I click on the Airport icon on my menu bar.

    I can connect to it by selecting the network manually and it only takes a second to do so, but I'm wondering if I can have it automatically connect??

    Also, it seems to lose its connection when the computer goes into sleep or when I use fast user switching.

    Any help appreciated.


    PB 15" (M9422LL/A); Mac OS X (10.3.7)
  2. tamara6 macrumors regular

    Apr 28, 2004
    Does it lose the connection when you switch users or only when you have fast user switching enabled (even if you don't switch users)?
  3. blodwyn macrumors 65816

    Jul 28, 2004
    Portland, Oregon
    My 12" PB connects automatically whether switching users or waking up at home or at work, so it's probably a setting somewhere

    Have you got the location set to 'Automatic' in your Sysyem Preferences > Network?
  4. LimitedEdition macrumors member

    Jan 14, 2005
    I had that problem once too. Where you have put "join a specified network" you have to change it back to automatic.

    If you are worried that it will connect to someone else's network, I don't know this for sure, but in my experience it always connects to the last network it was on, even if other people's SSIDs are visible.

    Also it will remember the password in the KeyChain, so even though there is no password on the screen there it will be able to get on your encypted network.

    I think that part of the GUI is badly designed. It combines the fact of what to join and whether to join automatically in to one GUI control but they should be separate.
  5. frez thread starter macrumors member

    Jan 12, 2005
    Limited Edition .. you are truly a limited edition.

    Changed it to automatic and it works wonderfully .. thanks! :) :) :)

    2 days with OSX and so far so good.

    Now I descend into the rabbit hole (so I've heard) that is:
    networking my windows machine with my osx machine :eek:

Share This Page