Witcher 2 on base 27 with added Ram and Fusion

Discussion in 'iMac' started by Wakeywarrior, Jan 5, 2013.

  1. macrumors member

    Oct 14, 2012
    I'm playing Witcher 2 in OSX on my base 27 inch (didn't want to pay £320 more to upgrade to higher version and add on 680 which is what it costs in UK for what will be sparodic gaming) and it plays pretty good. I have it on high settings, but the resolution at 1280 x 720- no problems with it at all. The lack of RAM on the card only makes a difference if you go for native resolution. It looks fine at 1280x720.

    So anyone worried about gaming on base 27 inch iMac- don't- unless you want the most demanding games on the native resolution.

    I have Fusion and upgraded the RAM to 24GB- don't think the RAM makes much if any difference to performance of Witcher 2 though.
  2. macrumors member

    Dec 29, 2012
    The difference between 1440p and 720p is substantial. Obviously there is nothing wrong with enjoying the game at a low resolution! I can't wait till my iMac arrives on Monday, Witcher 2 is one of the first games I bought in anticipation (I am going to have quite a few games to play through this year).
  3. macrumors member

    Jan 2, 2013
    which GPU do you have, is it the 660m or the 675MX?
  4. macrumors member

    Nov 12, 2012
    I'm playing the mac native version on my rig in my sig at 1080p at medium settings, HD 6970 1gb ram, runs great and looks great...awesome game as well.
  5. macrumors member


    Aug 12, 2010
    Hoboken, NJ
    What kind of fps are you getting? It ran like crap for me on my 6970m 2GB. I had the i7 also. I tried lowering all kinds of settings and I couldn't get it much above low 30s fps. It would immediately dip when exploring.

    I just sold it for the new 680mx :).
  6. thread starter macrumors member

    Oct 14, 2012
    660. Just ran Dirt 2 on native res and it looks really good, much better than say a PS3, it was getting 99fps.

    Will have to bootcamp, suspect it will run the likes of BF3 good at medium settings native res.
  7. macrumors member

    Nov 12, 2012
    All i had to to do was disable ubersampling and anti-aliasing and motion blur...

Share This Page