world of warcraft not playing after i click "play" button. please help!

Discussion in 'MacBook Pro' started by dsprimal, Jul 4, 2010.

  1. macrumors 6502a

    dsprimal

    Joined:
    Mar 27, 2010
    #1
    i bought wow at a local store, put in the cd, installed everything + patches. opened the world of warcraft shortcut and clicked "play" in the world of warcraft window and then my screen goes black like its about to run WoW, but nothing happens. ive been forced to manually press the power button to shut down my mac. i've even went to the blizzard site or "battle.net" and put in the authentication code thinking that was my issue. but nothing happens still.

    ive never had wow, so i dont know if i need to setup a PAYMENT subscription 1st before playing, but isnt the 1st month free? i dont think this is the issue either tho. i dont see any WoW intro, or anything.

    please can anyone help me. thanks.
     
  2. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    Don't have any paid time right now, but the newest patch login screens seems to be at least getting me to the server and telling me i'm out of time.

    When I was playing, they did have some sever issues, and since there is a recent new patch and a holiday weekend ... having hangs on "connecting" wouldn't be too unusual.

    ---

    Where I'm at right now the connection is simply awful or i'd check further. Not even worth the effort when my connection is marginally above dial up.
     
  3. thread starter macrumors 6502a

    dsprimal

    Joined:
    Mar 27, 2010
    #3
    i dont even get to the menu screen, no music, no cursor, nothing. all black screen after clicking the play button :confused:
     
  4. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #4
    The forum will say if the newest version 3.3.5.12340 has problems with the i7.

    If you don't find anything.

    I would say, go to hotmail and sign up for a free e-mail account, and go to blizzard and sign up for a free trial account using the new email download the trial version -- or use one of the 10-day cards.

    If that gets you in and playing, simply sign in with your activated battlenet account and let it upgrade the trial version of the downloaded app to full.

    Generally the shortcut i've always used has been World of Warcraft Launcher.app which shows the news and downloads, prior to starting WoW.
     
  5. macrumors member

    Joined:
    Jun 3, 2010
    #5
    It doesn't make any difference if you don't have a subscription/account it should still allow you to get to log in screen. Do you have the latest software update?
     
  6. thread starter macrumors 6502a

    dsprimal

    Joined:
    Mar 27, 2010
    #6
    i dunno, the updates musta installed like 10 patches. how can i get the latest one?
     
  7. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #7
    Just try archiving the current install (to a .zip file) and download a copy of the trial (which should work) and see if it gets you in to play.

    Then simply type in the active battle-net account, and let it update the trial to full version again.

    Sometimes it is a pain, but sometimes you have to download again if something gets really screwed up.

    ---

    Only reason i mentioned trying the trial download first it should be a version that will work with you current machine, which isn't always the case with the version on the DvD.

    ---

    EDIT

    Looked again, tried to redo a trial, didn't work, but the black screen is it trying to download a huge new trailer (what a freaking pain with a slow connection) and it looked like a slight change to login for me darn drop down sub accounts replace by new screen (wasn't used to that).
     

Share This Page