WoW Latency issues.

Discussion in 'Games' started by Laplace, Oct 8, 2005.

  1. Laplace macrumors member

    Joined:
    Aug 14, 2005
    Location:
    Huntsville, AL
    #1
    Im running 10.4.2 on a Powerbook G4, latest rev. 128 VRAM, 1.5Gig DDR RAm. I have a cable connection and Airport Express wireless router that I use to connect to the internet.

    Out of game my internet connection is fine, often reaching speeds of 100MB+ downstream, airport signal is full strength. In game though is another story, my connection is TERRIBLE, latency issues abound, with a ping of about 2000-3000ms consistently. This is in non crowded zones at non crowded times throughout all times of the day. OCCASIONALLY i get a brief few seconds where i have a ping of about 200ms, but even then the game still functions as if I was lagging. Symptoms include but not limited to:
    1: when selecting objects or items or when casting spells or attacking, there is a delay that often occurs in me getting killed, it is a pretty severe delay.
    2: chat is delayed severely as well
    3: sometimes the game just doesn't respond to anything for minutes at a time, then it "wakes up" and i am dead usually.

    I have had the game for about a week, and this has been giong on ever since I received it and logged in the first time. Is there some kind of firewall issue here, or do I need to open some certain ports on my router? I'm at a loss here. Any help is greatly appreciated. At this rate, I cannot effectively play the game, which is a shame, because I have really come to like it(even with the severe lag).

    I did a traceroute and I have included the results for further troubleshooting. I also called your phone ttech support and they advised me to rename 3 folders in my WoW directory which I did, but to no avail.

    1 10.0.1.1 (10.0.1.1) 1.590 ms 1.066 ms 0.911 ms
    2 10.99.216.1 (10.99.216.1) 10.316 ms 10.072 ms 20.476 ms
    3 user-24-96-110-117.knology.net (24.96.110.117) 11.046 ms 10.042 ms 13.554 ms
    4 ge.1-1-0.cr-hunt.al.us.knology.net (24.214.2.161) 9.904 ms 33.394 ms 34.544 ms
    5 * so.2-2-0.cr-atla.ga.us.knology.net (24.214.0.221) 18.274 ms 20.678 ms
    6 ge-6-6.car1.atlanta1.level3.net (63.211.121.5) 17.036 ms 20.418 ms 17.687 ms
    7 ae-1-51.bbr1.atlanta1.level3.net (4.68.103.1) 17.394 ms 16.744 ms 20.400 ms
    8 as-1-0.bbr1.washington1.level3.net (4.68.128.201) 30.007 ms 31.748 ms 29.413 ms
    9 ae-13-53.car3.washington1.level3.net (4.68.121.80) 45.910 ms ae-13-51.car3.washington1.level3.net (4.68.121.16) 32.197 ms 4.68.121.144 (4.68.121.144) 38.042 ms
    10 level3-gw.wswdc.ip.att.net (192.205.32.41) 32.752 ms 35.681 ms 35.167 ms
    11 12.122.80.229 (12.122.80.229) 86.911 ms 85.773 ms 85.652 ms
    12 tbr1-cl4.sl9mo.ip.att.net (12.122.10.30) 88.618 ms 87.302 ms 119.048 ms
    13 tbr2-cl2.sffca.ip.att.net (12.122.10.42) 89.224 ms 92.958 ms 86.411 ms
    14 gar3-p370.sffca.ip.att.net (12.123.13.161) 85.361 ms 100.854 ms 87.206 ms
    15 mdf1-gsr12-2-pos-7-0.lax1.attens.net (12.122.255.254) 93.838 ms 97.976 ms 113.632 ms
    16 mdf1-bi8k-2-eth-1-1.lax1.attens.net (12.129.192.242) 97.514 ms 119.613 ms 95.370 ms
     
  2. Verto macrumors 6502a

    Verto

    Joined:
    Jul 20, 2005
    Location:
    Denton, TX
    #2
    you have all the appropriate ports open for the router and firewall? I set up a new router and didn't open up the ports; I could still join, but my latency was terrible.
     
  3. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #3
    I have been having some major lag problems over the past week or so, you might want to give it a little more time. As Verto said, I would definitely check the firewall first. Another thing you can try is to set your MTU value lower than the default. A value of 1454 is what worked for me. For ethernet you can set it in System Prefereces>Network>Ethernet, but for Airport you cannot, and would have to install a startup script. But you can test it in Terminal by typing:
    Code:
    sudo ifconfig en1 mtu 1454
    and then trying WoW (the value will reset to 1500 the next time you reboot).
     
  4. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #4
    Oh, by the way, the firewall ports I have open for Blizzard/WoW are:

    4000, 6112-6118

    and for Blizzard Downloader (WoW patches):

    3724, 6112, 6881-6999
     
  5. Laplace thread starter macrumors member

    Joined:
    Aug 14, 2005
    Location:
    Huntsville, AL
    #5

    Excuse the ignorance but im not sure what the MTU values is? Is this a router setting? i have turned my software firewall off, but that didn't help either.
     
  6. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #6
    I think it stands for Maximum Transmission Unit or somesuch. Basically it describes the maximum size of a packet sent out from your computer. The default value of 1500 is fine for most people. However, certain setups and ISPs (mine is Earthlink) have a problem with that size, and the value must be lowered a bit, otherwise you will get intermittent internet access with lots of slowdowns and halts (like having to click "send" two or three times to send an email, submit a web form, or upload a file via ftp). The idea is to keep the MTU value as high as possible while making sure it's not getting "stuck". This can be tricky to determine as the effects can appear somewhat random. 1492 works for some people, others must lower it more. Whether this would affect games such as WoW, I'm not sure, but it affected pretty much all internet access for me. Just try entering the number in the Terminal as a test, as I said it will automatically reset to 1500 the next time you log in or reboot.
     
  7. OutThere macrumors 603

    OutThere

    Joined:
    Dec 19, 2002
    Location:
    NYC

Share This Page