WoW Patches AFTER 1.9.0 patch will REQUIRE Mac OS X 10.3.9

Discussion in 'Games' started by yellow, Jan 3, 2006.

  1. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #1
    From the World of Warcraft 1.9.0 patch from today..


    Plan accordingly..
     
  2. ssj300 macrumors member

    Joined:
    Jun 14, 2005
    #2
    which means wow be playable on the intel macs

    time 2 buy 1
     
  3. Mord macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    UK
    #3
    oh noes, seriously who runs 10.3 and if they do why the hell not 10.3.9, i'm on a "break" atm, oh and pallys suck they are the official n00b class.
     
  4. yellow thread starter Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    You'd be surprised how many folks I read on various forums who don't update and are still languishing at 10.3.6 or 10.3.8 for various legitimate and illigitimate reasons..
     

Share This Page