WoW What is going on????

Discussion in 'Games' started by JLaFrance, Dec 24, 2004.

  1. JLaFrance macrumors member

    May 24, 2004
    Alright, ill make this short and sweet, something is not right. When i go the the character pick screen, my character is all drawn out to the right hand side and all that are normal are weapons. Also, when im in the game, i cant see other players or NPC's, can there is all this spindly crap flying all over the place. Just got it today and installed and patched, everything was cool. Running a 1GHz eMac, 768mb ram, 10.3.7. I played in the open beta and that worked just fine. What's the deal?? (pic attatched)


    EDIT: pic didnt work...dunno how to make it so
  2. Rezet macrumors 6502a


    Apr 21, 2003
    Connecticut, United States of America
    Maybe because it's an eMac? I don't know man. You better off go to blizzard with that stuff. I doubt it's a common problem. It's unlikely people will give you a solution here.

    Did you mess around with emacs hardware at all?
  3. Jigglelicious macrumors 6502


    Apr 25, 2004
    Disable vertex shaders. Then restart the game. That should fix your problem. This is a known issue with the latest patch, where WoW incorrectly identifies certain video cards (in your case, a Radeon 7500) as supporting vertex shaders, when it really doesn't.
  4. Larzstar macrumors newbie

    Dec 25, 2004
    G4 Issues with WoW

    I'm having basicly the same Issues with a G4 1000, 768 Meg, with a 64 Meg nVIDIA GeForce4MX.

    The Character looks to be to the right of the screen represented as a bunch of lines. I see names moving around me with sometimes Hair and always a weapon moving. I've set all shaders to Zero and that didn't help.

    I've attached a JPG screen capture .... if that helps
  5. rbarris macrumors 6502

    Oct 28, 2003
    Irvine CA
    There is a bug in the current patch where the vertex shader feature will get incorrectly enabled on cards that don't support it. The solution should be to go to the video options dialog and turn off the vertex animation shader. Be sure to quit and relaunch the game afterwards.
  6. Larzstar macrumors newbie

    Dec 25, 2004
    I DO NOT know

    I pressed ESC
    I went through EVERY Video option that had a yellow check mark by it .... clicked that off. Quit the game. Launched the game .... SOS (do I need to translate SOS?)

    I pulled the PieceaCrap (PC for short) out of the Closet....(Sinfull isn't it?) Installed the game .... Played the game just fine. Shut Mac off ... turned PC off ... Went to bed to think.

    Yesterday I decided to TRY it on the Mac again. Well it worked just fine. So I slowly went though all those things I'd turned off. Quit game ... launched game....after each check mark I made .... Just to find the offending one.

    Well I turned every one BACK on and it worked Just fine.!???? hummmm.... Played the game for couple hours ON THE MAC ... shut Mac off went to bed to think. Well TODAY the game is all @#$% again. hummm ... back into the video options .... every thing back off ... Quit game ... Launch game ... SOS .... Shut computer off. Turned computer on ... I Get into game and???? WORKS JUST FINE!!!!!!!!!!!!!!
  7. starstreak macrumors 6502

    Dec 5, 2004
    That's funny. I noticed that too. First I saw my portrait of my character in game. (Hit C) and it was all messed up. Later on, when I played the game it was ok. Go figure.
  8. pgc6000 macrumors 6502a

    Jul 12, 2004
    Don't touch the things you turned off. Leave it. Changing it is going to mess the game again. If you can't run it on the Mac just use your PC. What else are you going to do?

    But, is this another mistake from Blizzard?? Didn't they ship a ton of copies Warcraft III without the mac version on the back? I don't know too much because I have never bought a Blizzard game.

Share This Page