Writing with Greek Fonts

Discussion in 'Mac Apps and Mac App Store' started by 18thTomorrow, Sep 1, 2004.

  1. 18thTomorrow macrumors 6502

    Joined:
    Apr 5, 2004
    Location:
    The Alpha Quadrant
    #1
    Hello,
    I'm studying Greek this fall and want to take some notes and do some writing on my laptop. I've downloaded/installed some Greek fonts--HellasHelvecia, and HellasTimes, etc. However whenever I try to use them in Appleworks or another application, they just come out as english fonts.
    What am I doing wrong--is there some setting that I need to have enabled?
    Thanks
    18
     
  2. Wes macrumors 68020

    Wes

    Joined:
    Jun 22, 2001
    Location:
    London
    #2
    Apple: System Preferences, International.

    Once there, input menu, look for Greek in the menu, tick it. Select it in the input menu.
     
  3. 18thTomorrow thread starter macrumors 6502

    Joined:
    Apr 5, 2004
    Location:
    The Alpha Quadrant
    #3
    Thanks for the reply. I did this and logged out and then back in; however, when I try to select Greek in the input menu, it is greyed out and not "selectable".
     
  4. Wes macrumors 68020

    Wes

    Joined:
    Jun 22, 2001
    Location:
    London
    #4
    Hmm to be honest I don't know what it could be, as I never change language I just always knew the option was there. In options try un-checking "Try to match keyboard with text". Maybe that's doing it because you don't have a Greek KB. (Can it even tell that?)
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    I tried the suggestion and have the same problem - maybe using an application like Pacifist to install the additional fonts/languages from the Mac OS X CD will help?
     
  6. jmm macrumors newbie

    Joined:
    Aug 27, 2004
    #6
    Greek on Mac

    Perhaps these are Unicode fonts? That would explain if they do not work in AppleWorks. If you are using OS X, try TextEdit instead.

    If you want to write classic Greek, you will need the GreekKeys input method and a classic Greek font like Athenaean.
    <http://ist-socrates.berkeley.edu/~pinax/greekkeys/GreekKeys.html>

    Hope this helps.
     
  7. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #7
    Actually, it's probably because the app you're trying to write in doesn't support unicode - Office X, probably?

    Office 2004 adds unicode support. In the meantime, you can use TextEdit and try saving as an RTF for compatibility with other word processors.

    edit - jynx, jmm. :p
     
  8. 18thTomorrow thread starter macrumors 6502

    Joined:
    Apr 5, 2004
    Location:
    The Alpha Quadrant
    #8
    Ah! That must be it. I can do it in Text Edit. Duh...Try harder next time, Britt...

    thanks for the help!
     
  9. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #9
    You may need to add Greek to the Languages: list. In the International Preferences pane, press the Language tab. Press the Edit... button. When the list appears, scan down the list to select the languages that you want.
     

Share This Page