wxWidgets for Mac

Discussion in 'Mac Programming' started by ScKaSx, Oct 21, 2006.

  1. macrumors regular

    Joined:
    Feb 27, 2006
    #1
    Hi All,

    Has anyone tried using wxWidgets (2.6.3) for Mac OSX. I installed the software in accordance to what (www.wxwidget.org) says to do. I have been trying to run the sample programs through Terminal. However when I type 'make' for the samples I get the following error:

    (this example for Display.cpp)
    ld: can't locate file for: -lwxtiff-2.6
    make: *** [display] Error 1

    I assume I haven't done the installation correctly or need to install a library or something. Please let me know what's going on if you know.

    Thanks,
    ScKaSx
     
  2. macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #2
    I had no problem building it on Mac OS X 10.4.8 (Intel) just now.

    What OS X version are you building on and is it completely up to date? Did you download the Mac-specific package and did you not notice any warning/error from ./configure?

    Code:
      Which libraries should wxWidgets use?
                                           jpeg               builtin
                                           png                sys
                                           regex              sys
                                           tiff               builtin
                                           zlib               sys
                                           odbc               no
                                           expat              builtin
                                           libmspack          no
                                           sdl                no
                                           gnomeprint         no
                                           hildon             no
     
  3. thread starter macrumors regular

    Joined:
    Feb 27, 2006
    #3
    Everything apears up to date

    I'm running it on 10.2.9, so still on the PPC. But the site said it wouldn't have a problem with that. I've run fink install update so I'm pretty sure everything in the backend is up to date. when I configured it got to that "which library do you want" stage and then stopped. I wasn't quite sure what it was asking there. Did you choose one of the options? Thanks

    Cheers,
    ScKaSx
     
  4. macrumors 6502a

    Sayer

    Joined:
    Jan 4, 2002
    Location:
    Austin, TX
    #4
    The configure program is showing you which kinds of libraries for the various graphics and other file formats it will use.

    Code:
    builtin - native support in the OS or software you are building
    sys - installed discrete library typ. libpng, libtiff, libjpeg etc.
    no - not available
    
    Usually all you have to do to get a UNIX software distro up and running is:

    Code:
    ./configure
    make
    sudo make install
    However there may be dependencies on other software packages that are not part of your OS that you need to supplement to get the software to build from source. Usually libpng, libjpeg, libtiff are what come up all-too-often.

    So you may need to do a "make clean" and then re-run ./configure and check the last bit to see what libraries you are missing, and go and get them, and build them first and then build wxWidgets.
     

Share This Page