X11 remote networking problems

Discussion in 'macOS' started by cobra01977, Sep 10, 2005.

  1. cobra01977 macrumors newbie

    Joined:
    Mar 26, 2005
    #1
    I'm trying to connect to my university's linux server via ssh, all is well except when I want to use an application that isn't command line based and requires an X window, when I use it on the university internal network it's fine and I suspect it now doesnt work because I'm behind a NAT firewall, how can I get around this (preferably while still using NAT)
     
  2. cobra01977 thread starter macrumors newbie

    Joined:
    Mar 26, 2005
    #3
    no I always use that on my login, when i start an x application is says "" display not found
     
  3. cobra01977 thread starter macrumors newbie

    Joined:
    Mar 26, 2005
    #4
    I think it's because my computers ip address can't be seen (due to NAT)
     
  4. cube macrumors G4

    Joined:
    May 10, 2004
    #5
    The server does see an address, that given by the router.
     
  5. cube macrumors G4

    Joined:
    May 10, 2004
    #6
    Does the server have "ForwardX11 yes" in /etc/ssh_config ?
     
  6. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #7
    Do you not have to still set the server display environmental variable if you use ssh -X, as you used to have to with telnet? I'm not sure -- I'm just asking.
     
  7. cobra01977 thread starter macrumors newbie

    Joined:
    Mar 26, 2005
    #8
    I've solved it now, I opened the X server port on my firewall, it works, just slowly
     
  8. cbiffle macrumors member

    Joined:
    Jun 19, 2005
    Location:
    Tempe, AZ
    #9
    Then they probably have X11 forwarding disabled on the server.

    The -X option on ssh forwards the X traffic back through the ssh connection itself -- you shouldn't have to open a port on your firewall.
     
  9. cube macrumors G4

    Joined:
    May 10, 2004
    #10
    No. ssh does it
     
  10. cobra01977 thread starter macrumors newbie

    Joined:
    Mar 26, 2005
    #11
    well I opened the ssh port and x windows actually and it worked after that
     
  11. cube macrumors G4

    Joined:
    May 10, 2004
    #12
    You are not forwarding. The ignored -X option is not needed.
     
  12. cobra01977 thread starter macrumors newbie

    Joined:
    Mar 26, 2005
    #13
    Ah, I see thanks
     
  13. cube macrumors G4

    Joined:
    May 10, 2004
    #14

Share This Page