Xbox 360 and Tiger internet sharing question

Discussion in 'Games' started by Modano, Nov 30, 2005.

  1. Modano macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #1
    Hi everyone-
    Just hooking up my new 360 and I can't get Tiger's internet sharing to work with it. I have it hooked up to my Quad and have my cable modem in one ethernet port, the 360 in the other, and internet sharing enabled but the 360 can't get an IP. The only thing I could think of is that I might need a crossover cable. Is that right? Any help would be appreciated.
    Thanks!
    'dano
     
  2. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #2
    Yup, if you've started sharing and all that, you have to have a Cross-Over Cable.
     
  3. Modano thread starter macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #3
    That's what I thought. I know Macs will automagically deal with that sort of connection with a regular ethernet cable, but suspected that the 360 might not. I'll pick one up on the way home tomorrow. Thanks!
     
  4. G5Unit macrumors 68020

    G5Unit

    Joined:
    Apr 3, 2005
    Location:
    I'm calling the cops
    #4
    So if I got an Xbox 360 and hooked it up to my PM(G5) for LIVE i would have to buy another cable? Also, would I get a lot of lag? D-Link Router->PM(Airport Extreme)->Xbox 360
     
  5. Modano thread starter macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #5
    You could connect it directly to your router and not have to get another cable. My Mac has 2 ethernet ports so I'm connecting the xbox directly and have to get a crossover cable.
     
  6. Laser47 macrumors 6502a

    Laser47

    Joined:
    Jan 8, 2004
    Location:
    Maryland
    #6
    Lol, I like that word ;)
    I think that all macs have auto-duplexing ports, atleast my ibook does so I would think the PM has it also.
     
  7. shadowmoses macrumors 68000

    shadowmoses

    Joined:
    Mar 6, 2005
    #7
    I use my mac mini's AE to provide my xbox with Live, it works fine even if i have low reception there is no lag and play never drops works faultlessly,

    SHadow
     
  8. Modano thread starter macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #8
    I got a crossover cable but this still isn't working. My xbox can't get an ip address. Anyone got any advice?
     
  9. clayj macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #9
    Have you tried just manually assigning an IP address to the 360? The only way it can automagically get an address is if you have a DHCP server there (a router, or an actual server)... also, bear in mind that your broadband provider may only provide ONE IP address to your residence. It doesn't sound like you have a router or a DHCP server (for local NAT), so that could be a BIG problem.
     
  10. Modano thread starter macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #10
    I could do that, but with Internet Sharing on, Tiger is supposed to assign clients ip addresses. Do you know what the IP range for a typical internet sharing setup is? I could just assign it one and see if that works, but it will have to be on the same subnet that my Mac is expecting.
     
  11. Modano thread starter macrumors regular

    Joined:
    Jun 23, 2003
    Location:
    New Orleans
    #11
    OK something is definitely wrong here. I broke down and bought the wireless adapter for the Xbox after neither crossover or standard ethernet cables worked and it sees my network but can't get an ip address! What could be going on? I don't have any kind wep enabled. Any ideas?
     
  12. shadowmoses macrumors 68000

    shadowmoses

    Joined:
    Mar 6, 2005
    #12
    Set your 360's IP adress to: 192.168.2.1 and then set the default gateway to 192.168.2.2

    Also set you DNS serers to whatever yours are amd you should be good to go,

    Shadow
     
  13. kyo00 macrumors newbie

    Joined:
    Dec 26, 2005
    #13
    Hi at all
    i have connect modem usb to imac...and imac(whit internet sharing on) to xbox360 with the cable exit in the x360 full box...

    ...my problem is the NAT=Moderate....

    ..i have set ethernet of the mac(manual):

    ip 192.168.0.1
    mask 255.255.255.0

    ....in xbox360

    ip 192.168.0.2
    mask 255.255.255.0
    gateway 192.168.0.1

    DSN (i type Dig in terminal)

    now i play in Live! but MODERATE...where is the problem???
    thanks
     
  14. Moog101 macrumors member

    Joined:
    Jul 20, 2004
    Location:
    London, UK
    #14
    If you're using any tpe of firewall, you'll have to do some port forwarding.
    If you open up the following ports, it should change your NAT from moderete to open..

    Ports...

    88
    53
    3074

    M
     
  15. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #15
    Ok here's a checklist you can do:
    1. Make sure Internet Sharing is on the correct port. If you have two Ethernets and you connect via AE then make sure you have the right Ethernet. Otherwise make sure you have Internet Sharing (IS) enabled on that port and turned on - yes you can stop it and start it.

    2. Firewall, make sure the firewall is turned off or your have the specific ports enabled. Check your XB360 Documentation to make sure you have the right ports (I don't have one, but I assume it should tell you).

    3. Use DHCP to get your IP Address - this makes things so much easier. On the XBox side if you can't do DHCP try Manual. IP Address: let's say your router is 192.168.0.1 - set your IP Address to 192.168.0.3 or whatever is available. Set your Gateway/Router to 192.168.0.x x being your PowerMac G5 Address - set that on the XBOX.

    4. Check connections and lights. Make sure one is blinking. Now make sure the PM has connection to the internet, then try the Xbox360.

    Those are a few tips I can give you. The Gateway/Router I had to do that on my iMac G3 when I was linking it up so it routed through there.
     
  16. JDOG_ macrumors 6502a

    JDOG_

    Joined:
    Nov 19, 2003
    Location:
    Oakland
    #16
    I've got a 50' ethernet cord running from my AE to my 360. It works pretty freaking well but looks like a camel's arse.

    From the title I thought this thread was about getting the media streaming features to work from a mac.
     
  17. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #17
    I got my xbox 360 to work with my powerbook sharing internet from airport.
    People pm'd me asking how so here's the reply I sent them - hope it helps someone

    I'm not great with ip addresses, unfortunetly I've had to learn via trial and error (probably the best way)...


    Anyway here's what i did on my mac so you've got an idea where to start.


    1 - Network settings

    Airport Settings. Leave those as DHCP so that they find your wireless router and connect to the internet. You don't need to modify these at all.

    Ethernet Settings.

    With ethernet enabled DHCP would'nt give me an ip address and when choosing network status I would have the message, theyre may be a problem with your connection... So in order to get this to work with the 360 I had to assign it an ip address.

    So i entered:

    ip address 192.168.0.20
    Subnet mask: 255.255.255.0

    I left the other field blank at this stage. apply those settings and check network status from the show drop down menu and hey presto my status had gone from yellow to green.

    2 - Sharing

    Services - I have windows sharing ticked and personal file sharing ticked.

    Internet - I have share from Airport selected with from Ethernet port ticked on the bottom.

    Click Apply

    ------------------------

    Now to the Xbox 360

    In network settings I again had to give my machine it's own IP Address as it wouldn't see it (FAIL)

    So I gave the machine the following

    IP Address: 192.168.0.21
    Subnet Mask: 255.255.255.0

    But here's the important one again Router: 192.168.0.20 the ip address I had assigned the mac ethernet port.
    ---------------------

    Test connection IP Address (CONFIRMED) DNS (FAIL)

    -------------------------
    So now we need to work out the DNS settings. This is what killed me with Trial & Error. (SCREAMING might help too ;))

    I tried loads of permitations and putting my aiport settings into it but no good. What I tried eventually and got working was that the DNS setting has to be the TC/IP address of the wireless router that you are connected to (not the airport in your mac).

    In my case I have an Aiport Basestation which assigns an ip address of 10.0.1.1

    This is probably in your Airport setting pages listed as Router: 10.0.1.1 or depending on what you are using as a wireless router.

    This is the DNS setting to use on the xbox 360 settings.

    So DNS Primary: 10.0.1.1 (or whatever ip address your wireless router/access point has)
    DNS Secondary: 10.0.1.2 (I just went one up - but you might get away with the same setting as primary).

    ----------------

    Test connection and fingers crossed CONFIRMED all the way.


    I hope that helps you. Again happy new year to you.
     
  18. kakarotto macrumors newbie

    Joined:
    Jan 5, 2006
    #18
    hi everyone, this is my first post :)
    i'm italian,so...sorry for my bad english :rolleyes:
    i've a powerbook g4 with tiger and airport connected to the Router Airport Express.
    I've been able to connect xbox360 by ethernet so it work with my powerbook sharing internet from airport,thanks to MacRumorUser's guide
    I've a problem with the NAT:i've Moderate.
    I've seen i've to open these ports
    88
    53
    3074
    and i've tried to,but without success..
    i've opened the Airport Utility,then i've gone to the config page.
    Then i chose MAP. PORTA(in italian...it's the fourth option,see the Photo),i've added 88,53,3074(for the ip,i've set the Mac one, 10.0.1.2)
    But the nat is still moderate...
    where am i wronging??
    [​IMG]

    Thank you for help
     
  19. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #20
    Sorry, this thread, I don't know anyone who has been successfully been able to get this working or not. It's something that I'd have to tinker with, but I don't have an XBOX360. Sorry ummm... as far as I know you've done everything correct, and welcome to the MacRumors forum.
     
  20. kakarotto macrumors newbie

    Joined:
    Jan 5, 2006
    #21
    ok, thank you :)
    Hope someone knows it..
     
  21. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #22
    I'll tinker around with the settings see if I can find a solution. If I do I'll post them. I worked out the other stuff so I'm hopefull I guess... :rolleyes:
     
  22. kakarotto macrumors newbie

    Joined:
    Jan 5, 2006
    #23
    ok, thank you ;)
     
  23. kyo00 macrumors newbie

    Joined:
    Dec 26, 2005
    #24
    kakarotto anche io sono italiano
    io ho lo stesso problema tutto ok tranne nat moderato

    io ho un modem usb coolegato al imac ed l'ethernet collegato alla xbox360

    le configurazioni le puoi vedere sopra

    scusa ma se ha il firewall inattivo serve aprire le porte 88,53 e 3047??


    aiutamoci

    tua tag sul live??
    mia kyo00
     
  24. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #25
    Not a perfect translation, but you can figure it out:
    kakarotto also I am Italian I I have the same problem all ok except
    nat moderated I I have a connected modem usb to the imac and the
    ethernet connected to xbox360 the configurations you can to them
    excuse but if it has the inactive firewall serves to open doors 88,53
    and 3047

    aiutamoci

    --Used Translation Widget = Percent Estimated correct translation: 85%
     

Share This Page