XCode download from App Store will not work in Lion DP4!!!

Discussion in 'Mac Programming' started by WardC, Jun 24, 2011.

  1. macrumors 68030


    Oct 17, 2007
    Fort Worth, TX
    I just downloaded the latest version of XCode from the Mac App Store and I tried running it on Lion DP4 and it will not run!!! It will not even run the installer.

    It tells me I need XCode 4.1, but this is not downloadable from the App Store -- this is the latest version they had to download (which is 4.0.2). I no longer have my Snow Leopard install on my disk. Did I just waste $5.00 to download XCode or will I have to wait until 4.1 is released and re-purchase it? Much help would be appreciated. Thanks.
  2. macrumors newbie

    Jun 24, 2011
    I guess you have to wait for an update for Xcode, will probably be fixed by the realease of Lion.
  3. macrumors 68000


    Jun 9, 2004
    Rochester, NY
    First of all, if you were a registered developer then you would probably know that there is a developer copy of Xcode that runs on Lion available for download from Apple's site. :) I don't mean to sound snarky, but if you obtained Lion legally through developer.apple.com, the link to the Xcode preview is hard to miss.

    Second, updates to applications purchased through the Mac App Store are always free, so once 4.1 is released to the public, you'll be able to update your current 4.0.2 copy to the newer version.
  4. macrumors G5


    Nov 25, 2005
    It's a "Developer Preview". Read your license that you agreed to. You have no right to post any complaints about it anywhere, and you don't even have the right to complain.

    And anyone having a _legal_ copy of the Developer Preview can download XCode directly from Apple without going through the App Store.

Share This Page