XCode Freezing

Discussion in 'iOS Programming' started by dgdosen, Jul 15, 2008.

  1. macrumors 65816

    dgdosen

    Joined:
    Dec 13, 2003
    Location:
    Seattle
    #1
    Anyone ever have an issue with XCode freezing during "Building" of a project?

    I'm on an 8-core Mac Pro, and it sometimes XCode just freezes during a build. I need to kill it in Activity Monitor, then start it up again.

    Anyone have the same issue? I'm hoping for an update to the SDK soon to do a re-install
     
  2. macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #2
    Yep, having the exact same problem. Once it happens once, it happens pretty much every time within the next 10 minutes too. Did you ever find a fix? :confused:
     
  3. Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #3
    Is it completely frozen with the SBOD, or can you still move windows and the cursor appears normally? If the latter, open up Terminal and see if you get an error. If so, use Activity Monitor to force quit all gcc* and cc* processes and then rebuild.

    If none of that applies, sorry, can't help ;)
     
  4. thread starter macrumors 65816

    dgdosen

    Joined:
    Dec 13, 2003
    Location:
    Seattle
    #4
    Well - forcing the app to quit is the only way to fix it. That also usually breaks the ability for NSLog information to hit the console, so I usually wind of restarting and taking a break...

    It's annoying, but at least there's a work around.
     
  5. macrumors newbie

    Joined:
    Jul 11, 2008
    #5
    I have had this happen for the past week or two, I think it's a problem with the latest release.

    It may just be superstition, but if I have my SCM disabled in xcode (as in not set up rather than offline) I don't seem to have it happen.
     
  6. macrumors regular

    Joined:
    Apr 4, 2007
    #6
    Exactly :(
     
  7. thread starter macrumors 65816

    dgdosen

    Joined:
    Dec 13, 2003
    Location:
    Seattle
    #7
    I'm not using svn or any SCM so I can't blame that. I blame XCode!
     
  8. macrumors newbie

    Joined:
    Jun 29, 2007
    #8
    I'm glad it's not just me. This is such an annoying issue, and it's frustrating that it got past Apple's QA (though XCode 3.1 is clearly still in beta, whatever Apple says.) I've found it necessary to restart my computer when it starts happening, or it will occur every few builds.
     
  9. macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #9
    This is exactly what happens to me too. :mad: It's amazingly frustrating to restart your machine every 10 minutes, and halting your progress. I really hope Apple gets this worked out. They must be having the same issues? Don't they use Xcode to write Xcode?
     
  10. macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #10
    I've opened a bug report with Apple, and they asked for a sample of the hung state using the Activity Monitor, so we'll see if this gets anywhere. :rolleyes:
     

Share This Page