XP Network Printer

Discussion in 'Mac Basics and Help' started by Lucky8, Jun 3, 2005.

  1. Lucky8 macrumors regular

    Lucky8

    Joined:
    May 18, 2005
    #1
    I can see my XP shared network printer (Canon i470D) from my PM G5 running Tiger.
    But when I try to print, in print queue box its saying "Connection failed with error. NT_STATUS_ACCESS_DENIED" Then after a few minutes, "Unable to connect to SAMBA host, will try in 60 seconds...ERROR: Connection failed with error"

    After a couple tries and resets, now it's giving me this messege: "Connection failed with error NT_STATUS_NO_MEMORY"
    Can sombody please Help Me...
     
  2. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #2
    Here is the link for the latest drivers - for all supported OS's

    http://alpha02.c-wss.com/inc/ApplServlet?SV=WWUCA900

    According to Canon you will need these latest drivers for the printer to work properly under Tiger.

    The error is generated when you do not have an account on the Windows PC.


    Here how to share your PC printer:
    For OS X 10.3.7 up...
    Add the TCP/IP print server service

    In Windows XP

    1. Log in with Administrative privileges.
    2. Click Start -> Settings -> Control Panel.
    3. Double-click Add-remove Programs.
    4. Click the Add-Remove Windows Components side button.
    5. Open the Other Network File and Printer Services section.
    6. Put a checkmark in Other Print Services.
    7. Click OK; click Next. (The Computer will probably ask for the WinXP install disk, go ahead and put it in and the install will run automatically.)
    8. Click Finish.
    9. Close the Add-remove programs window.

    To have the service start automatically (as a daemon):

    1. Click Start -> Settings -> Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Double-click TCP/IP print Server.
    5. Change the "Startup Type" to Automatic.
    6. Click OK and close the windows that are open.

    To share the printer for TCP/IP printing:

    1. Click Start -> Settings -> Printers.
    2. Right-click the print you want to share and select Sharing.
    3. Click the radio button for Share as and fill in the share name you want to print to.

    Make sure you have a declared IP address on this XP box:
    1. Click Start -> Control Panlel -> Network Connections
    2. Right-click on your network connection (usually "Local Area Connection" or "Network Bridge") and click "Properties".
    3. Select "Internet Protocol (TCP/IP)" and click "properties"
    4. If you have a static IP address, make a note of it. If you have "obtain IP address automatically" select the radio button below it "use the following IP address" and make a note of what you determine.

    On your Mac:

    1. Launch the Print Center.
    2. Click the "Add Printer" button.
    3. Change "Appletalk" to "IP Printing"
    4. Printer type "LPD\LPR"
    5. Enter the WinXP Computer's IP address in the Printer Address box.
    6. Enter the Printer name in "Queue Name" box
    7. Select your printer model (Install Gimp-Print if you don't see a ppd for your printer, restart print center and try again).

    Or on the Mac:

    1. From Printer Setup Utility
    2. Choose "Windows Printing" and "WORKGROUP" from the drop down menus.
    3. Any printers set up as shared on any windows machine on the same subnet will then show up by selecting the name of the windows machine.
    4. All you need is an account on that windows machine - you don't need to know the IP address.
    5. You do have to enter a user name to avoid the error in the original post.


    Written by Zukutu
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Or, for a one-line response:

    Create an account on the Windows PC with the same username and password as on your Mac.
     
  4. amartins02 macrumors newbie

    Joined:
    Mar 10, 2005
    #4
    lol that was easy. But cheers on the effort.
     
  5. Lucky8 thread starter macrumors regular

    Lucky8

    Joined:
    May 18, 2005
    #5
    I'm still getting the same error messege eventhough sometimes it'll just sits there in the print queue.

    I did everything Simie said to do on my XP box. Besides it didn't ask me for the XP disc, I also noticed "Print Server for Unix" under "Other Network File and Printer Services" section, it's still 0MB. I figure if we install something there it shouldn't give me 0MB.

    Is there anything I did wrong?
     
  6. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #6
    If Windows XP doesn't ask for the CD, its because you have a copy of the i386 folder on your hard drive, this was copied there during the installation of XP.

    Try logging into Mac from your PC

    1. Open up search
    2. Choose Computers and People
    3. Choose A Computer on a Network
    4. Enter the IP address of your MAC i.e. 192.168 1.4
    5. Now search
    6. Double click on your MAC's IP Address once it as been found.
    7. Enter your User Name and Password
    8. Choose the option for windows to remember the user name and password. It's just a tick box on the same windows that you have to log in with.

    Go to your Mac and you should now be able to print.
     
  7. Lucky8 thread starter macrumors regular

    Lucky8

    Joined:
    May 18, 2005
    #7
    I can see my Mac from PC but I still can't print from Mac.
    :confused: :confused: :confused:
    It keeps giving me error messege "Connection failed with error. NT_STATUS_ACCESS_DENIED" Then after a few minutes, "Unable to connect to SAMBA host, will try in 60 seconds...ERROR: Connection failed with error"
     
  8. Lucky8 thread starter macrumors regular

    Lucky8

    Joined:
    May 18, 2005
    #8
    Now it keeps giving me error messege "Connection failed with error. NT_STATUS_NO_MEMORY" Then after a few minutes, "Unable to connect to SAMBA host, will try in 60 seconds...ERROR: Connection failed with error"
    Please HELP!
     
  9. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #9
    Check any firewall that you have - is allowing communication from the mac to the windows box. Try disabling it.


    On the mac,
    1. In finder you have the GO menu, select utilities and then open the Network utility. Goto ping - and enter the IP of the PC and see if the two computers are communicating.

    2. Open up the printer utility and select more printers, from the top box select Windows Printing and from the second box select Workgroup, if you get nothing in the window below then try selecting Network Neighborhood and your printer should appear.


    3. In System Preferences / Sharing, make sure you have , Windows File Sharing ticked.

    Back to Windows

    4. On your Windows box make sure that the printer is being shared.

    5. In windows check the account name that you set up, make sure it is exactly the same as the account on your mac.
     
  10. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #10
    Do you have the printer shared on your XP box? By Network Sharing Wizard? - Or in your network settings, enable network file and print sharing on the ethernet card.
     

Share This Page