Yahoo Mail IMAP with Apple Mail

Discussion in 'Mac Apps and Mac App Store' started by hanguolaohu, May 12, 2011.

  1. macrumors regular

    Mar 5, 2007
    After using Yahoo Mail IMAP for years on my iPhone, I was excited when I read a Wikipedia article stating that one can use IMAP on Apple Mail for the desktop also. I followed the instructions listed here:

    These are the settings:
    Incoming Server -
    Outgoing Server -
    Incoming Port - 993 (requires SSL)
    Outgoing Port - 465 (requires SSL/TLS)
    Username: full email address (for example, or
    Password: the password you login to Yahoo! with.

    But I'm not able to send out emails. I double checked my Outgoing server and Outgoing Port settings, and I also tried the Connection Doctor and the light goes green stating "Connection and login to server succeeded". I'm not sure what is wrong. Any advice would be most appreciated!

  2. macrumors Core


    Jul 24, 2006
    The Ivory Tower (I'm not coming down)
    I thought you had to have the premium service to get Yahoo mail on a desktop client?
  3. macrumors member

    Dec 8, 2005
  4. thread starter macrumors regular

    Mar 5, 2007
    I finally got it to work because I discovered a typo :p Thanks for the link karl.

    miles, that's only for POP mail. We're talking about IMAP.
  5. macrumors newbie

    Dec 28, 2010
    I had been using macfreepops with yahoo for quite some time. I recently discovered that I can use my free yahoo account on the mac mail client and switched over. It was working fine for awhile with the setting I had used. (can't remember what they were now) and then all of a sudden one day is stopped working. So, I began fiddling with the servers and settings. Now I got it to work just fine with one exception, my sent folder has a little globe next to it and there doesn't appear to be a sent folder at all. I can't see my sent messages. I have the following settings:

    incoming server-
    user name- myusername (without the

    smtp port 465
    use SSL
    authentication- password
    username- entire yahoo email address

    Advanced settings
    IMAP path prefix- INBOX
    port 993
    Use SSL
    authentication- password
    use IDLE command is DEselected

    Am I missing something here? Anyone else have the problem of a globe where there should be a folder?
  6. macrumors G4

    Jul 17, 2002
    What problem?

    With POP3 accounts, you get a folder.
    With IMAP accounts, you get a globe.
    You setup Yahoo! as an IMAP account.
    You got a globe.
    This is exactly what you should have.

    What problem?
  7. pierat, Jun 7, 2011
    Last edited: Jun 7, 2011

    macrumors newbie

    Dec 28, 2010
    I have 5 other email accounts, all IMAP, and none of them have the globe. When the yahoo account shows the globe, it seems like there is no folder assigned to that task. (drafts, sent, etc.)

    I have switched around the settings a little and my account is now working again, along with another yahoo account. For some reason, the second yahoo account only works on port 995 while the first one is on 993. Also, I am not using any IMAP path prefix right now. Things seem to work like this but I don't know why.

    Edit to add: And then, just like that, the first account stopped working. I switched the port to 993 and it seems to be back. Does anyone know if there are any settings that will actually work all the time? I understand this isn't really supposed to work at all, but I'm hopeful. Worse comes to worst, I can switch back to macfreepops. :-(
  8. macrumors 65816


    Feb 10, 2003
    Buckeye Country, O-H
    Yahoo! IMAP now supported.

    I did a clean install of Lion the other day, and just updated my laptop to ML, and noticed when putting in my email accounts on both that Yahoo, has finally allowed IMAP support for any account; and not just paid subscribers.
  9. macrumors G4

    Jul 17, 2002
    IMAP support in Yahoo! Mail has absolutely nothing to do with Mountain Lion. To the best of my knowledge, Mail has always supported IMAP. Yahoo! Mail IMAP is IMAP. I have had my Yahoo! Mail account setup in Mail as IMAP on my PM G5 running MacOS X 10.4.11 (Tiger) for months.
  10. macrumors 65816


    Feb 10, 2003
    Buckeye Country, O-H
    Did you have a free account with yahoo, or were you a paid subscriber? And yes I do know that it doesn't matter what OS you are running, it depends on what the Mail server supports. I just happened to notice it after installing ML, and Mail wanting me to update my settings.

    When I was a paid subscriber with AT&T Yahoo DSL years ago, it wasn't available. They aways forced POP. Maybe its not 'new', but this has been the first time that it has worked for me by default.
  11. macrumors G4

    Jul 17, 2002
    My Yahoo! Mail account is free. In the past, you had to pay for a Yahoo! Plus account to gain access to Yahoo!'s mail servers. However, access to them has been free since at least February 2011. When I learned that Yahoo! was accessible via standalone email clients like Mail, Thunderbird, and Outlook Express, I setup my Yahoo! Mail account in Mail as IMAP and have not looked back.

    I infer from this MacOS X Hints webpage that Yahoo! dropped the Yahoo! Plus requirement around the same time that it adopted IMAP or soon thereafter.
  12. thread starter macrumors regular

    Mar 5, 2007
    Actually this worked since the release of Lion...

    Since the release of Lion, Apple Mail has supported the quick setup of Yahoo Mail IMAP (free or paid) accounts.
  13. macrumors newbie

    Sep 24, 2012
    Yahoo IMAP on Mac Outlook 2011?

    Hi folks - just reading this thread on how Yahoo (free) works in IMAP within Apple Mail (it does work for me, running Mountain Lion).

    I'm new to Mac, so perhaps I'm missing something, but I'm also running Outlook 2011 for Mac. I've tried to set up Yahoo IMAP within Outlook, but to no avail.

    And, a few perhaps related points:

    - In the Mac Outlook menu, under "Tools", "IMAP Folders" is disabled (greyed-out)

    - Similarly, I cannot create a new folder. That is, in the menu, under "File", "New...", "Folder" is also disabled (greyed-out.)

    Should I expect to get Yahoo IMAP working in Mac Outlook 2011?

    Many thanks -
  14. macrumors newbie

    Apr 16, 2013
    For BT users I think I have a workaround (that may work for all clients). Not my ideas but a combination of suggestions given by other users.

    A combination of the following seems to have worked for me.

    1. Go to "Spotlight" on your Mac, top right corner. Type "keychain access". When the pop up screen appears, make sure in the left column you have both the following tabs selected. "Login" & "passwords". From there look through the list in the columns you have and delete EVERY mention of "yahoo" i.e. "". Basically, if you see a line with Yahoo in it, then get rid of it.
    • Go to your Yahoo email account on your browser, before you login deselect the tick box that asks you if you want to stay signed in. After logging in, log out.
    • Go to "Mail" on your Mac and open up the prefernce pane. Go to accounts and channge the servers for your BT Yahoo email accounts to the following.
    • Incoming Server -
    • Outgoing Server -
    • Restart "Mail". On some of my yahoo email accounts this worked instantaneously for me. On others it took around 5 minutes for the account to start working again.

    12 hours in and the problem seems to be gone.

    Good Luck to all.
  15. macrumors regular

    Jan 6, 2011
    People's Republic of Chicago
    Thanks for the efforts, but unfortunately the above still doesn't work for me. I've also walked through the set up for Yahoo mail 3 times now with an Apple care person on the phone. It's not that I can't get Yahoo mail - I can, it's just that Mail asks for my Yahoo password every 5 min. Of course I've selected the "remember this password" option, and I'm running SL although I don't know why that would matter. Out of my 7 other email accounts (POP and IMAP), it's the only one that has this and it is pretty annoying. Not sure what the trick is. I've cleaned out the passwords in keychain many times to no avail. Anyone else?
  16. macrumors 68020


    Feb 28, 2009
    I'm getting the same behavior - every few minutes, re-enter the Yahoo password.

    What I suspect is either that Yahoo:

    * screwed something up in their new email system


    * is trying to get people off of IMAP, so they're making it hard to use on purpose

    With the latter, they can't serve ads etc.

    This isn't a configuration error on your side.
  17. macrumors 65816

    Aug 16, 2007
    I'm also getting the "re-enter password" dialog box also. Very annoying. I just earlier tried to set up my Yahoo Mail on Mac Mail and it seemed to work. All my messages loaded and everything seemed fine. Then a window popped up asking me to re-enter my password. It keeps coming up every few minutes for me as well. Is there any solution. I even check the box that says to remember password in keychain.
  18. mic j, Apr 30, 2013
    Last edited: Apr 30, 2013

    macrumors 68020

    Mar 15, 2012
    I had the problem for a while, then it went away for a week or two, now it is back. I really believe it's a Yahoo Mail issue as when it went away, it was not due to anything I did in Mail to correct the issue. Interesting, I have 2 accounts with Yahoo and only one of them is having the issue, it uses POP. But the account with the issue had it when it was using POP. I changed to IMAP and that did not help. I have also noticed that when Mail contacts the Yahoo servers, the account without the issue searches very fast, the account with the issue searches for a much longer time. I tried everything I could (instructions above plus lots of other suggestions) to correct the issue with no luck.

    So I solved the problem. I started using gMail. No issues. Shame on you Yahoo.

    Edit: Oh, I should also say that while I am in transition to gMail, I have been taking the Yahoo account offline so I don't have to continually deal with bouncing icons and re-entering passwords. Once or twice a day, I take it back online to retrieve any mail on the Yahoo server. It works perfectly, no request for a password.
  19. macrumors 6502a

    Feb 12, 2008
    When you reboot your computer and launch for the first time, the bouncing icon starts. Then in that window you can see the “Show certificate” button. Click on that. Then at the bottom there is a trust widget, click on it, and from the dropdown you can “trust this server.” That solved the problem for me.

Share This Page