Yet another...website critique

Discussion in 'Design and Graphics' started by aricher, May 8, 2006.

  1. aricher macrumors 68020

    aricher

    Joined:
    Feb 20, 2004
    Location:
    Chi-il
    #1
    Hello all,

    Being that my web skills are next to nil I created the following portfolio/design archive site using iWeb. I'm well aware that it looks very template-based and I'm fine with that for now. When I have some downtime I intend to pick up Dreamweaver, etc.

    I have a ton to add into the photography section but am waiting on the arrival of a new film scanner. Any feedback on the layout, content, page order, etc. would be much appreciated. Also, any comments on load times (.mac hosting) would be helpful. Link in signature. Thanks.
     
  2. aricher thread starter macrumors 68020

    aricher

    Joined:
    Feb 20, 2004
    Location:
    Chi-il
    #2
    Ok, so no feedback eh? That's alright. Really, the highlight of the site is a goofy Magnum-P.I. spoof I did in iMovie. Enjoy:

    Magnum-Esque P.I.
     
  3. j26 macrumors 65832

    j26

    Joined:
    Mar 30, 2005
    Location:
    Paddyland
    #3
    Your images are far too big - it takes a while to open properly because of that unless you're on superfast broadband.

    The 3 images alone on the front page are over 400kb and they're only supposed to be thumbnails.. The Event Marketing page graphics are about 500kb Shrink them and it will be far more responsive. there is no need to have large files as thumbnails. I know you say it's designed to be viewed on high speed internet, but not everyone has that, and by the time you're aware of your little discalimer, you've probably moved on to another site.
    If you want work out of this site, it pays not to be too picky and limit it to people on fast connections. The slideshows can be hi-res, but there is no need for the main body of the site to be.

    As far as the overall feel of the site, I think that the colour in the backround is dull and doesn't do your work any justice.

    Edit, looking at it again, it seems that you are preloading the images in the slideshows as thumbnails. It's making the site sluggish.
     
  4. kretzy macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #4
    I quite like the look of the site. It is nicely laid out, simple, and no excess nonsense. The only thing that bugs me a little bit is the stencil font you've used. I just have a thing against stencil fonts in general, so don't take it personally. ;)

    Nice job! :)
     
  5. aricher thread starter macrumors 68020

    aricher

    Joined:
    Feb 20, 2004
    Location:
    Chi-il
    #5
    Good to know - will look into replacing all thumbnail images with lower-res versions.

    It originally was black but on most PCs (different gamma) everything looked VERY dark. What would you suggest?

    I've been going back & forth on that - having trouble finding something I like.

    Keep it coming folks - savage it if you must. I need some constructive criticism.
     

Share This Page