You can now remove recent email addresses from Mail

Discussion in 'iOS 6' started by HazyCloud, Sep 23, 2012.

  1. HazyCloud, Sep 23, 2012
    Last edited: Sep 23, 2012

    HazyCloud
    Expand Collapse
    macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #1
    This is something I've seen others complain about on here, as well as myself. Before, if you typed a letter when addressing an email, you'd see all the email accounts you've ever sent an email to. To remove these you had to restore as new as that was the only way to get these deleted from Mail.

    Now, Apple gives us an easy way to remove them. Just click on the > button and you'll be given the option of Create New Contact, Add to Existing Contact, or Remove From Recents.


    EDIT** It appears they are also synced via iCloud. I just opened my iPad which had a few for the letter 'A' and now they are gone even though I didn't remove them from the iPad, just the iPhone.
     
  2. KeanosMagicHat
    Expand Collapse
    macrumors 6502a

    Joined:
    May 18, 2012
    #2
    Whilst seemingly a small change, this is really useful. I had an address in there for a works email from my previous job and it was quite annoying having to have the nimble fingers of a surgeon to avoid sending mails to the wrong address.

    It should be noted that you can only delete the addresses from the recent list if they are not stored anywhere in your contacts, which makes sense.
     
  3. HazyCloud
    Expand Collapse
    thread starter macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #3
    This is true. If you'd like to remove a certain email address that's stored in one of your contacts, you'll need to remove it from Contacts. If it still shows up, go back to Mail and remove it from there.
     
  4. interconnect
    Expand Collapse
    macrumors regular

    interconnect

    Joined:
    Nov 15, 2007
  5. KeanosMagicHat
    Expand Collapse
    macrumors 6502a

    Joined:
    May 18, 2012
    #5
    As you start to type the email address and the offending one appears, you will see a blue arrow beside it.

    See the attachment below;
     

    Attached Files:

  6. KeanosMagicHat
    Expand Collapse
    macrumors 6502a

    Joined:
    May 18, 2012
    #6
    When you click the blue arrow, you now have the option to remove the address from your recents list for good.

    Again, please see the picture below. Unfortunately I don't seem to be able to add multiple pictures to the same post from my iPhone, sorry.
     

    Attached Files:

  7. interconnect, Sep 23, 2012
    Last edited: Sep 23, 2012

    interconnect
    Expand Collapse
    macrumors regular

    interconnect

    Joined:
    Nov 15, 2007
    #7
    Unfortunately I don't have that option... I just checked. I wonder if it's because I'm using Gmail configured as an Exchange account.

    Also, since I setup Facebook integration now all my Facebook contacts show up in that list. I've chosen to hide them by going to "Groups" in Contacts and deselecting the Facebook contacts, but they still show up in the recents... anyone discover a way to clear them out (aside from the way above where I'm assuming you'd have to go one-by-one)?
     
  8. mantan
    Expand Collapse
    macrumors 65816

    Joined:
    Nov 2, 2009
    Location:
    DFW
    #8
    This was a LONG overdue change that was very much appreciated.
     
  9. Pb4543
    Expand Collapse
    macrumors newbie

    Joined:
    Feb 21, 2015
    #9
    Meaning of Recent

    How long are contacts kept on this 'recents' list? Why do some addresses get tagged in the drop down as 'recent' whilst others, equally unused and expired, don't?


     
  10. HazyCloud
    Expand Collapse
    thread starter macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #10
    I honestly don't know. I can't seem to find any rhyme or reason why they act they way they do. At least we can remove them.
     
  11. AmazingKerem
    Expand Collapse
    macrumors 6502a

    AmazingKerem

    Joined:
    Oct 29, 2012
    Location:
    ✭ London, UK ✭
    #11
    Is this option available in newer versions of iOS?
     
  12. C DM
    Expand Collapse
    macrumors Penryn

    Joined:
    Oct 17, 2011
    #12
    Yes, it's still there.
     
  13. Curly Howard
    Expand Collapse
    macrumors newbie

    Curly Howard

    Joined:
    Jun 17, 2015
    #13
     
  14. Curly Howard
    Expand Collapse
    macrumors newbie

    Curly Howard

    Joined:
    Jun 17, 2015
  15. C DM
    Expand Collapse
    macrumors Penryn

    Joined:
    Oct 17, 2011
    #15
    Same way as before now that it has been fixed in iOS 9.1.
     
  16. Curly Howard
    Expand Collapse
    macrumors newbie

    Curly Howard

    Joined:
    Jun 17, 2015
    #16
    Well if I do that I will loose my jb but hey thanks for letting me know that 9.1 will work with this.
     
  17. Curly Howard
    Expand Collapse
    macrumors newbie

    Curly Howard

    Joined:
    Jun 17, 2015
    #17
    I tried this and it works:

    Sveta replied on October 18, 2015 - 12:02am PERMALINK

    I have the same problem on my iPad iOS 9.0.2
    Your e-mail addresses are stored on the iCloud server - not on the device.
    Login into your account www.iCloud.com from any desktop or laptop computer (mine is Windows) via a web browser (mine is Firefox). Click on the mail icon. Compose a new mail and start to enter the name of the contact. You will see a list of suggestions from contacts with red (delete) button for each e-mail on the right (that option not available from iPad). Delete unwanted address. Log off from a computer.
    Compose a new message from your iPad the unwanted email address will not appear in the autofill list.
     

Share This Page