youtube HD

Discussion in 'MacBook Air' started by byke, Dec 31, 2008.

  1. macrumors 6502a

    byke

    Joined:
    Mar 29, 2007
    Location:
    LDN. UK
    #1
  2. macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    yeh its not smooth on my MBP. most likely due to Flash being over CPU intensive in OS X. however i have watched other HD YouTube videos fine.
     
  3. macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #3
    Definitely, a huge difference between HD and the regular video... I even ran it on my Mac Pro 3.0 and there was still some jerkiness going on throughout the HD video...:eek:
     
  4. macrumors member

    Joined:
    Apr 29, 2007
    Location:
    London, England
    #4
    In terms of playback frame rate, the footage was totally smooth on my MBP (both cores ~75%) though camera shake from the acquisition was still very apparent (as true with the low-res version).

    I totally agree though, flash is a dog on OS X.
     
  5. macrumors 6502a

    macjram

    Joined:
    Dec 20, 2008
    #5
    It jerked a little on mine

    but I'm on a HP Pavilion dv6000 =[
     
  6. macrumors 6502a

    Joined:
    Dec 1, 2007
    #6
    To get HD enabled, you have to render it again at the higher HD resolution and re-upload. Could it just be badly dropped frames when the author rendered it and uploaded to youtube?
    I've tested many 1080p youtube videos on the MBA and smooth as silk.
     
  7. macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    上海 (Shanghai)
  8. macrumors 65816

    tubbymac

    Joined:
    Nov 6, 2008
    #8
    Nope.

    Nope.

    The reason I say this is that I did a test with my MB Alum and the linked video randomly stutters while loading on Mac OSX under Safari but is perfectly smooth under my customized bootcamp install under Vista 32 and Firefox. By customized I've taken the default install with Apple's junk drivers and force upgraded to current drivers.

    So looks like either an issue with flash under OSX or an Apple driver issue. I've seen the same stuttering on other HD youtube videos under OSX while the same ones play perfect under Windows.
     
  9. macrumors 6502a

    mhnajjar

    Joined:
    Mar 3, 2008
    #9
    I just tried it on my wife's Vaio and it ran silk smooth under FireFox. I am too lazy to turn on any of my Macs at this time!
     
  10. macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #10
    It's a little jerky on my G4 Powerbook too. :D I think its getting close to time for an upgrade.
     
  11. macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #11
    Damn!

    Ironically the video plays MUCH better in Windows. I have a MBA Rev B/SSD and that HD video stutters in OS X. I booted up to Windows Vista (bootcamp) and the video plays a whole lot better with only a very slight stutter at the beginning and played smoothly till the end. I hate that flash is better in Windows. I just don't really know why?
    Anyone have insight to this?

    EDIT: Although it did play better in Windows on my MBA I tried it on my 24" 2.8Ghz iMac and the video played perfectly without a hiccup even while it was loading. Go figure.
     
  12. macrumors regular

    pgharavi

    Joined:
    Nov 25, 2004
    #12
    The video is jerky if it plays while it loads. If I pause it and wait for it to load completely, it plays fine.
     
  13. macrumors 65816

    tubbymac

    Joined:
    Nov 6, 2008
    #13
    Ready for some wild speculation? :) Adobe Photoshop is much faster and efficient on Windows than on OSX given the same machine. Apple refuses to add flash support to Safari on the iPhone. Put those two together and my guess is there's some bad blood between Apple and Adobe and there is some back and forth chest beating going on between those two. When they kiss and make up suddenly flash and photoshop will get awesome under OSX.

    I get the same behavior. Most likely it has to do with both flash being badly programmed on OSX and the broadcom wireless driver being a piece of garbage. It's a big pain to get a bootcamp install to not stutter with the POS that is broadcom's wireless drivers under windows, so I imagine Apple has similar headaches writing the driver under OSX.

    As long as the broadcom wireless isn't downloading/uploading while the flash video is playing it doesn't seem to stutter on HD on OSX on the notebooks. iMacs I don't know if they have the broadcom wireless or if they use a different driver.
     
  14. macrumors 65816

    mabaker

    Joined:
    Jan 19, 2008
    #14
    The video is absolutely unwatchable on my Dual G5. It's rather a disgrace how Apple and Adobe handled the Flash implementation in Mac Os X.
     
  15. macrumors 603

    NC MacGuy

    Joined:
    Feb 9, 2005
    Location:
    The good side of the grass.
    #15
    It's not super awful on mine as long as I let it load all the way before I play it and don't have a boatload of windows open.
     
  16. macrumors regular

    quovadis

    Joined:
    Oct 30, 2006
    Location:
    in PA
  17. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
  18. macrumors 65816

    Joined:
    Jan 15, 2009
  19. macrumors 68020

    juanster

    Joined:
    Mar 2, 2007
    Location:
    toronto
  20. macrumors member

    Joined:
    Oct 3, 2008
  21. macrumors 6502

    Joined:
    Jun 5, 2008
    #21
    Here's what you need to do to get youtube videos to play SMOOTHLY. Pay attention now, it's very simple.

    Go to Adobe.com and download the latest flash player version. As of today, it's version 10.0.22.87

    After installing this, all youtube videos, even HD videos, played silky smooth, both on my C2D MBP, and on my PB G4.

    If you have choppy youtube, chances are your installed flash version is 9.x which sucks hairy goat balls. Upgrade now!
     
  22. macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    Milano, Italy
    #22
    Done...still some stuttering present on my rev.B 1,86 SSD when palying back the fully downloaded video.....must be a Flash/OSX issue.....:(
     
  23. macrumors 65816

    mabaker

    Joined:
    Jan 19, 2008
    #23
    Powerbook G4 playing flash HD video smoothly? :eek:

    I find it hard to believe, but thanks for your input, Wotan! I am here completely resigned on my Powermac G5 dual which won't play any single flash HD video cuzz the perfoamnce is abysmal. ABYSMAL.
     

Share This Page