YouTube is extremely laggy in Safari (not in Firefox)

Discussion in 'Mac Basics and Help' started by mgpg89, Apr 26, 2012.

  1. macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #1
    I love Safari (so don't tell me to switch to Firefox) but YouTube has been super laggy lately.
    Choppy playback, slow buffering, unresponsive website overall. But in Firefox, it works just fine.

    Does anyone know what may be causing this?

    Cheers
     
  2. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #2
    Try disabling all add-ons or plug ins you have in Safari and see what happens. Also, try resetting it to its factory settings as well.
     
  3. macrumors newbie

    Joined:
    Feb 28, 2011
    #3
    I've been experiencing the same thing. I complete reset Safari and nothing has changed. I still unresponsive play/pause button. Videos don't start playing for a while, and then when they do, they're extremely intermittent.
     
  4. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #4
    Do you all have the latest release version of Flash installed?
     
  5. thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #5
    Pretty much the same issues I'm having. Video/audio also aren't in sync anymore (the further on in the video, the more they drift apart).

    Do you have any extensions installed?

    I tried disabling my plug-ins/extensions/add-ons, but that didn't solve anything.
     
  6. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    For Flash-related issues:
    • Find your Flash version and make sure it's the latest version available. Never install or update Flash from a pop-up on a website. Always go to Adobe's site to get Flash or updates.
    • Install ClickToFlash (Safari), Flashblock (Firefox) or FlashBlock (Chrome) to control which Flash content plays on websites.
    • Try using the YouTube HTML5 Video Player to watch YouTube videos, when available. (May impact fullscreen viewing. See link for details.) As far as performance impact, YMMV.
     
  7. thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #7
    Thanks, updating Flash solved the issues I was having. Can't believe Flash doesn't auto-update though! (or at least notify you when there's an update available)
     
  8. macrumors newbie

    N0k14 D14B10

    Joined:
    Apr 26, 2012
    #8
    Yhea on my desktop youtube doesn't Even play, but my fav browser is GC by far
     
  9. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #9
    It does on my Macs though, but since the Flashback trojan I get my updates directly from Adobe.
     
  10. macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #10
    I might have to switch off of Click to Flash. Lately the QTKitServer is just eating all the CPU power on my Core 2 Duo.
     
  11. macrumors newbie

    Joined:
    Dec 20, 2012
    #11
    I have same issue in Safari. You Tube suggests resetting your cache and cookies in your browser or wait for the entire video to buffer. I find it funny that the advertisements play perfectly as soon as you click on the video, but the video lags. I've updated my Flash but it didn't resolve anything.
     

Share This Page