YouTube is slow on the iPad

Discussion in 'iPad Tips, Help and Troubleshooting' started by crazycat, Jun 1, 2010.

  1. macrumors 65816

    crazycat

    Joined:
    Dec 5, 2005
    #1
    When I watch a YouTube video on my iPad I would have to wait for it to buffer up and sometimes takes 6 mins to view a 3 min clip.

    On my laptop i would just open the video and watch it without any load time, it seems the loading of the video is anywhere from x2 to x5 times faster on a laptop. Is there any king of fix for this problem.

    Thanks
     
  2. macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    London, UK.
    #2
    I'm having exactly the same problem. I tested the YouTube app and the mobile site, and the same thing happens. I found that it's not only YouTube, but any site that streams very high-res video, where I have the same issues.

    Again, there's no issue on my mid-range laptop, and hi-def videos work with no buffering issues, on the same Wi-Fi network. :mad:
     
  3. macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Central London & West Midlands, UK
    #3
    I'm having the same issue, albeit sporadically. Sometimes the video loads fine, other times it takes years. Really strange. I do have a fairly slow connection but YouTube's fine on my desktop.

    Annoying.
     
  4. macrumors regular

    Joined:
    Dec 30, 2008
    #4
    Yeah, this is something I've been experiencing, though nothing like 6 minutes of waiting for a 3 minute video. I wonder why this is considering the iPhone app is very quick for me on the same network, and on my laptop. Hopefully this is simply a software issue that can be resolved in a point update, or in OS 4.0.
     
  5. macrumors newbie

    Joined:
    May 6, 2009
    #5
    my 32g wifi model was delivered today with the same problem
     
  6. macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #6
    Are you guys using the youtube app or using the website.

    I have had better luck using the website compared to the app.
     
  7. macrumors member

    Macpowered

    Joined:
    Feb 4, 2009
    #7
    No problems here.
     
  8. macrumors 68030

    Arran

    Joined:
    Mar 7, 2008
    Location:
    Atlanta, USA
    #8
    Try turning bluetooth off.

    Worked for me - although it might've been coincidence?
     
  9. macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    London, UK.
    #9
    Ive tried both and the problem occurs whenever I try to stream high def video.
     
  10. macrumors 6502a

    Joined:
    Mar 13, 2010
    #10
    It's so annoying.
     
  11. macrumors 6502a

    sheppy1

    Joined:
    Sep 8, 2008
    #11
    I've had this problem once so far and I've watches a tone of YouTube videosmon my iPad, all I did to fix it was to reboot my modem and router and voilà they started working properly again with no waiting for them to buffer
     
  12. macrumors member

    Joined:
    Sep 30, 2007
    #12
    No problem with my two ipads playing youtube 720p videos.
     
  13. macrumors regular

    Joined:
    Oct 23, 2008
    #13
    Same problem here. It's most annoying, because it makes youtube useless to me. I hope a fix for this comes out soon.
     
  14. macrumors demi-god

    MacRy

    Joined:
    Apr 2, 2004
    Location:
    England
    #14
    I'm getting annoyed with this problem too. Constantly having to wait for a video to buffer really takes the "magic" out of the iPad experience. Weirdly I watched an hour long streamed program from the BBC iPlayer site with no buffeting at all and in pretty high quality. Hopefully we will see a fix for this in a future update.
     
  15. macrumors regular

    Joined:
    May 10, 2010
    #15
    I've had no problems with Youtube on a 64G WiFi iPad through an 802.11g router and a cable modem as well as with an 802.11g router and DSL service.

    Check your network speeds with the Speedtest app.
     
  16. macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    London, UK.
    #16
    Agreed. The iPlayer interface is attrocious and you can't make a widescreen video fullscreen, but the videos play with high quality and zero buffering - the complete opposite of YouTube(native app or mobile site) on the iPad.
     
  17. macrumors 68000

    ajohnson253

    Joined:
    Jun 16, 2008
    #17
    It's usually YouTubes problem, not the iPad.
     
  18. macrumors 6502

    Joined:
    Aug 16, 2008
    #18
    Same here over wifi but it loads quickly over 3G but the quality is s#ht.
     
  19. macrumors 6502a

    LordOBoogie

    Joined:
    Jun 18, 2009
    #19
    Can't say I've had this issue.
     
  20. macrumors 6502

    Joined:
    Mar 13, 2008
    Location:
    United Kingdom
    #20
    I have this problem too. I appreciate that my BT extended reach broadband speed is crap (even though I pay the top rate for which others can receive up to 8x faster!). However, YouTube plays OK on my iMac and MacBook. If I remember rightly, when I first received my iPad just over 6 weeks ago YouTube played fine, but over the past few weeks it has become jerky and slow to buffer. Sometimes it doesn't buffer at all and I have to keep pressing play until buffering is complete - what a way to watch a movie - it's like having a stammer in my brain!

    I've tried resetting my modem and I've tied turning off bluetooth but neither of these change things. Anyway I want to use my bluetooth earphones so that is not helpful.

    The ipad has bee out a while now and though I appreciate that some issues and improvements will take a while, for some IMPORTANT problems Apple need to pull their finger out and get an interim update to solve them!
     
  21. macrumors 6502

    Joined:
    Feb 25, 2010
    Location:
    Manchester, UK
    #21
    Me too, it's very slow, I don't think it's a youtube problem, maybe the app has some issues, hopefully it'll be fixed in the next update.
     
  22. macrumors member

    Joined:
    May 24, 2010
    #22
    Same problem here, and I think my 3GS has the same issue but don't use it much for youtube.

    For those that say to reboot modem/router or test network speed, remember that on other devices (mac desktop, windows computer, macbook) the speed is just fine and videos play right away, yet on the iPad 6 minutes download for a 3 minute video when another device plays it right away is the problem.

    And I haven't noticed it on other sites/videos (ABC Player, Netflix, etc.), only youtube.

    As far as connection speed, desktop speedtest shows over 10 Mbps, though the test on the iPad only shows 2-3. But even 2-3 shouldn't increase youtube videos only by 1000%.

    And it appears to be a somewhat common problem, just google "youtube slow on ipad" to see lots of complaints.
     
  23. macrumors 65816

    Loves2spoon

    Joined:
    Jun 3, 2010
    Location:
    California
    #23

    Sorry to hear your troubles, I've had a wonderful youtube experience. Videos buffer for 2-3 seconds and plays very quickly. Have you tried resetting your modem/router?
     
  24. macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #24
    There has been discussion of YouTube throttling speeds in major traffic areas. I live in NYC and even on my MacBook I get buffering issues regularly. So it could be partially a regional problem.
     
  25. macrumors newbie

    Joined:
    Jan 2, 2010
    #25
    same here I thought I was the only one. I stil dont know why it only happen with youtube other streaming works like a charm, for example Air video.
     

Share This Page