Youtube upload help

Discussion in 'Mac Basics and Help' started by SoCalSrf91, Mar 2, 2009.

  1. macrumors newbie

    Joined:
    Mar 2, 2009
    #1
    ok so i have tried everything to get videos uploaded to youtube but nothing works imovie gives me a communication error timeout thin and in safari i use the beta uploader and it crashes safari after ti gets like 5% done and i tried the reg uploader on youtube and it started at 1 and i checked it at4 30 and it still didnt budge or upload idk what to do any help would be awesome
     
  2. macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Binghamton, NY
    #2
    Same thing happened to me. Export your videos to MP4 format if not done already, then upload. I had MOV files that would upload for hours and never complete. Hope that helps.

    If you've deleted or lost your iMovie project get yourself this app: http://www.squared5.com/

    Great for converting all types of movies to different formats!
     
  3. thread starter macrumors newbie

    Joined:
    Mar 2, 2009
    #3

    will it make my video upload if i convert it to mp4? because all mine have been comming out as m4v and that one i tried to upload was mov or m4v but it took 3hrs and didnt even start
     
  4. macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Binghamton, NY
    #4
    Don't use M4V. In my opinion and past experience, it is just bad. It can not be played on any DVD. I did a school track team DVD with about 90 minutes of footage in M4V format and the DVD was is terrible condition. Videos lagged and framing was way off.

    I hate to say it, but MPEG Streamclip will not play M4V videos properly. They will lag and framing will be off. I hope you didn't do what I did with my track videos - delete all the iMovie projects before knowing the problem with M4V. It totally screwed me over. However I was able to upload them to YouTube.

    YouTube has been updating their Upload System. And as far as I can see, it has become worse when working with a Mac user. M4V might not be accepted due to their new updates.
     
  5. thread starter macrumors newbie

    Joined:
    Mar 2, 2009
    #5
    ok so i started this in march and i still cant get videos to upload to youtube

    my safari crashes my imovie 09 says communication error and firefox crashes i dont know any other way to get them uploaded can someone please help me
     
  6. macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Binghamton, NY
    #6
    This is very strange. I've uploaded about 15 videos since we last spoke, and I have been having less problems every time. It used to be worse as I said before (The videos wouldn't upload). I don't know what your problem could be. How do you get the 'Communiation Error' message?
     
  7. macrumors 65816

    scienide09

    Joined:
    May 5, 2007
    Location:
    Canada
    #7
    Are your movie files within YouTube's filesize limit? I wouldn't think that this would cause Safari to crash, but you never know.

    Also, please try using caps and punctuation. The more people who can read your post, the more who will try to help.
     
  8. Guest

    Benguitar

    Joined:
    Jan 30, 2009
    #8
    I upload all of my videos via iMovie 09. I haven't had any trouble with that. Maybe you should try putting your movie/video in iMovie and uploading it from there? :)
     
  9. macrumors newbie

    Joined:
    Apr 20, 2009
    #9
    Make sure the video is less than 10 mins long and no bigger than 1 GB.
    I uploaded my video through imovie 09, the video supposedly uploaded fine, but never actually appeared on youtube. I then joined my youtube account with my google account and signed in using this, this solved my problem and videos went up fine.
    The only thing I can suggest is to make a really small 15 second video clip of only a few MB in size and try experimenting uploading that. At least you won't have to wait a few hours for a large video file to upload only to find it failed.
    Hope that helps
     
  10. macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Binghamton, NY
    #10
    I second this. Try some small video clips first. Thats a good idea.
     
  11. thread starter macrumors newbie

    Joined:
    Mar 2, 2009
    #11
    i have tried all of that and still youtube says cant upload video and imovie always says communication error i know its not my internet connection because when i had windows running in bootcamp a few months ago it all worked but i deleted bootcamp

    my movies are in m4v format(yes you can upload m4v to youtube)but it always gives me an error on youtubes website but only from my macbook
    and imovie 09 starts to upload it then it says it has 37 hours left then it quits
     

Share This Page