Youtube will not load any video all the way through

Discussion in 'OS X Mountain Lion (10.8)' started by Roofy., Aug 9, 2012.

  1. macrumors 6502a

    Jan 24, 2009
    I have been having problems with this the past few days and its gotten to a point that any video on youtube I play, will stop loading about halfway through and just end. (it will go to the related videos)

    I deleted my cookies and still nothing. I tried firefox and it was fine. So there is obviously something wrong with Safari.
  2. macrumors member

    Jul 17, 2011
    YouTube has been super slow lately because of the Olympics. Everybody is on YouTube trying to catch replays they missed, so that might be why you are having problems. Have you tried using a different browser?
  3. thread starter macrumors 6502a

    Jan 24, 2009
    That makes sense. I tried firefox for one video that wasnt working in safari and it did load though.

    Videos will straight up cut out. As if it were a real TV. (static, fuzzy screen or neon colors)
  4. macrumors 601

    Mr. Retrofire

    Mar 2, 2010
    Make sure you disable HTML5 and enable the Flash plugin. YT HTML5 is sometimes buggy.
  5. macrumors regular

    Mar 6, 2012
    I have the same problem. Whenever I go on youtube it just freezes and show beachball. It happens on both safari and chome. But when I view youtube on bootcamp under IE, it works fine.

    I have ML on retina macbook pro. This only started like 2, 3 days ago.

    I have tried enable HTML5 Trial last night, and it fixed the problem. But this morning it's not working anymore.
  6. thread starter macrumors 6502a

    Jan 24, 2009
    Thanks alot
  7. macrumors 6502a

    Feb 26, 2011
    Las Vegas, NV
    Yes, disable Youtube HTML5 player. It is really buggy.

Share This Page