Z600 iCal syncing problems

Discussion in 'Mac Apps and Mac App Store' started by bnemesis, Jul 26, 2004.

  1. bnemesis macrumors regular

    Joined:
    Jul 31, 2003
    #1
    I picked up a Belkin Bluetooth dongle for my iBook to sync my calendars and my contacts with my Sony Ericsson Z600. My contacts sync fine, but my calendar was totally messed up on the Z600. All of the times were messed up.

    I chose to delete all the calendars from the phone, and tryed again. Same results, except it was missing a bunch of appointments (dates and times were still messed up). I erased the calendar from the phone again. This time, I discovered that my problem with the times being off was that I had the wrong Timezone selected in settings. After changing this, I tried to sync again but the phone shows no appointments when the sync is over!

    When iSync was doing its job, it showed that it was transfering stuff to the phone, but nothing shows up.

    Should I do a master reset on the phone? Or is there some hidden setting in the phone that will really clear out the calendars?
     
  2. pyrotoaster macrumors 65816

    pyrotoaster

    Joined:
    Dec 28, 2002
    Location:
    Oak Park, IL
    #2
    Ah... the problem with Ericssons...
    I had the same problem with my T616 and my Powerbook, and the problem is really with the phone, not the Mac.

    The problem is that your phone is adjusting all the calendar times for a nonexistent timezone change.
    First, turn off the auto time zone adjustment on your phone.
    Next, delete your phone from iSync and then re-add it.
    Make sure the first sync is set to delete all the phone's old Calendars and then sync the phone to the Mac.

    If you're still having problems, try turning on time zone support in iCal and make sure you've got the right time set on the phone.

    That should fix the problem. Ericsson phones are great, but that problem drove me nuts for a good while.
     
  3. bnemesis thread starter macrumors regular

    Joined:
    Jul 31, 2003
    #3
    I tried what you suggested and it didnt work
    iSync shows that it is uploading something to the phone, but the calenders dont show up.

    I tried the timezone thing in ical, that didnt work.
    I tried a master reset of the phone and that didnt work.

    If only i would have had my timezone set up then I wouldnt have this problem. I did sync the first time!But now nothing shows up :mad:
     
  4. pyrotoaster macrumors 65816

    pyrotoaster

    Joined:
    Dec 28, 2002
    Location:
    Oak Park, IL
    #4
    Hmmm... Okay...
    Try this:

    Delete the phone from iSync
    Delete the phone from your Bluetooth Devices
    Re-pair the phone to your iBook
    Re-add the phone to iSync
     
  5. bnemesis thread starter macrumors regular

    Joined:
    Jul 31, 2003
    #5
    Tried all of that and nothing happened. :-(

    I sort of got part of it working now.

    I did a double master reset to the phone (just to make sure).
    I found that the phone messed up my calenders, so deleted and rebuilt them. Then paired the laptop to the phone. Told iSync to erase the phone then sync.
    Now it syncs up the first calender, but skips the other two.

    Is this the way it works?
    Or is it supposed to show multiple calendars all at once?
     
  6. bnemesis thread starter macrumors regular

    Joined:
    Jul 31, 2003
    #6
    OK.After a little more testing, I have found that it WILL show multiple calenders but NOT all day events (like birthdays and holidays).
    Which I find to be pretty stupid.

    Oh well. At least I can see my schedule now.

    Pyrotoaster, you live about 2 hours from me!
     
  7. PHARAOHk macrumors regular

    Joined:
    Feb 19, 2003
    #7
    I am having similar problems with my t616. The times on my phone's calendar are completely inaccurate. I have appointment that starts at 6:00 AM to 7:00 PM but the phone says 11:00 Am to 12:00 AM thew next day? I have tried everything here numerous times over.

    The calendar on my iPOd works perfectly though. I have even tried arranging the time on iCal differently and all kinds of stuff. Has anyone with a t616 successfully synced their calendar to phone? :confused: :confused: :confused:
     
  8. bnemesis thread starter macrumors regular

    Joined:
    Jul 31, 2003
    #8
    all I can say is make sure that your time zone setting is correct on the phone. its under settings->Time and Date->Advanced
     
  9. PHARAOHk macrumors regular

    Joined:
    Feb 19, 2003
    #9
    I reset the PRAM and PSU. My phone still displays the time 5 hours early and so does my other phone? I am stumped and irritated.
     
  10. PHARAOHk macrumors regular

    Joined:
    Feb 19, 2003
    #10
    OK I have it fixed. I was setting my phone as GMT not realizing that even though the time was correct you have to change the offset if needed. In Dallas the offset is -5. Apparently other phones are more user friendly and say LA, New York, ETC. Oh well, learned something new though.
     

Share This Page