ziphone 2.6 help

Discussion in 'iPod touch Hacks' started by engles, Mar 16, 2008.

  1. macrumors regular

    #1
    I was hoping someone could give me a step by step instruction of how to jailbreak a 16GB 1.1.4 iPod touch with ziphone 2.6 using mac osx leopard. I have read ziphone.org but cannot understand exactly what to do. Please help.
     
  2. macrumors 65816

    #2
    Plug Touch into Mac.

    Launch ZiPhone. Select Jailbreak Touch. Wait one minute. Done.
     
  3. macrumors regular

    #3
    even with the 16 gb cause before I've gotten the bsd loop error.
     
  4. macrumors regular

    #4
    ZiPhone was just updated. It works fine now, but you do have to do a fresh restore on your iPod before you run it.
     
  5. macrumors regular

    #5
    how exactly do i do that?
     
  6. macrumors 65816

    #6
    Plug it into your computer. Launch iTunes. Click on Touch. Hit Restore
     
  7. macrumors 6502

    #7
    You shouldn't need to restore unless you've already tried jailbreaking it.

    Just open ZiPhone, connect your ipod, click 'Jailbreak' and wait about 1 minute :)

    Worked perfectly for me :)
    Just jailbroke mine 30 minutes ago
     
  8. macrumors regular

    #8
    awesome it worked. Took me about 45 seconds to jailbreak my 1.1.4 16GB iPod touch.
     
  9. macrumors regular

    #9
    Yep, I decided to again start from scratch, so I did a Restore to v1.1.4, then used ZiPhone 2.6 and in 4 seconds, my 8GB iPod Touch was Jailbroken.

    A couple tips:

    The first things I installed were some "core" packages:
    BSD SubSystem
    Cydia package
    OpenSSH
    MobileTerminal

    This alone lets me access my iPT using WinSCP and PuTTY, so from that point, just about anything is possible.

    I then applied a few "tweaks" through PuTTY to get things working more properly. (ALL of these tweaks came form George Zhu's Blog.) The tweaks were:

    Code:
    chmod 777 /var/root/Library
    chmod 777 /var/root/Library/Preferences
    Code:
    chown -R mobile:mobile /var/mobile
    Code:
    chmod 4755 /usr/bin/login
    mkdir -p /usr/local/arm-apple-darwin/lib
    ln -s /usr/lib/libgcc_s.1.dylib /usr/local/arm-apple-darwin/lib/.
    When I login using MobileTerminal, I can always su root and tweak anything I want.
     

Share This Page