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 Apr 12, 2012, 08:23 PM   #1

Ruffian829
macrumors regular
 
Join Date: Jun 2008

.webarchive to .pdf or .jpeg?

Anyone know if/how I can save a .webarchive file as a PDF or JPEG? 
I just want to be able to view the page when I'm not on the internet, and if the page ever gets deleted I want to be able
to keep a copy. 
The page is an iCloud journal my brother made for my son's birthday, so it's composed of a bunch of images. I realize
that I can save the individual images but I'd like to keep a copy of the collage as well.

       

 Apr 12, 2012, 09:06 PM   #2

Dave Braine
macrumors 65816
 
Join Date: Mar 2008
Location: Warrington, UK

You don't need to be connected to the internet to view a webarchive file. However, you can always do a Print>Pdf>Save
as PDF. You can do that from the webpage without saving as a webarchive first.
__________________
PPC Mini, 10.4.11, Intel Mini, 10.6.4, White MacBook 10.6.4
Mk1 iPhone 3.1.3, using o2 PAYG

       

 Apr 12, 2012, 10:01 PM   #3

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

Quote:

Originally Posted by Dave Braine 
You don't need to be connected to the internet to view a webarchive file. However, you can always do a
Print>Pdf>Save as PDF. You can do that from the webpage without saving as a webarchive first.

In this case, it seems as if I do. If I turn off wi-fi I cannot view the webarchive on my mac or ipad, the page pops up and
it says "this journal is unavailable" vs. all the photos it normally shows. 
I tried the print>pdf>save as PDF and it did not work, it saved the page as 17 distorted pages of what appears to be the
individual pages (although there are more than 17 pics on the collage) they are all stretched and distorted it is hard to
even tell which "photo" is which.

       

 Apr 13, 2012, 03:19 PM   #4

Dave Braine
macrumors 65816
 
Join Date: Mar 2008
Location: Warrington, UK

Hmmm...maybe it's something to do with iCloud. I'm not familiar with how it works. Do you view it with Safari?
__________________
PPC Mini, 10.4.11, Intel Mini, 10.6.4, White MacBook 10.6.4
Mk1 iPhone 3.1.3, using o2 PAYG

       

 Apr 13, 2012, 06:00 PM   #5

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

I've viewed it in safari and Firefox but I was only able to save it as a web archive from safari.

       

 Apr 13, 2012, 09:42 PM   #6

Dave Braine
macrumors 65816
 
Join Date: Mar 2008
Location: Warrington, UK

In that case, I can't think why you can't view it offline. 
__________________
PPC Mini, 10.4.11, Intel Mini, 10.6.4, White MacBook 10.6.4
Mk1 iPhone 3.1.3, using o2 PAYG

       

 Apr 13, 2012, 10:04 PM   #7

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

I have no idea either. I didn't even realize it until I tried to show it to my grandmother (she doesn't have Internet).
That's why I was hoping to be able to save it as a Jpeg or PDF. 
Maybe I could take a bunch of screenshots and paste them together... Will prob come out like crap though... :-/

       

 Apr 14, 2012, 03:29 PM   #8

chown33
macrumors 68040
 
Join Date: Aug 2009

Post #2 already tells how to print to a PDF file. Try that.

       

 Apr 14, 2012, 07:14 PM   #9

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

Quote:

Originally Posted by chown33 
Post #2 already tells how to print to a PDF file. Try that.

Uh and post three says I already tried that and it did not work.

       

 Apr 14, 2012, 07:21 PM   #10

GGJstudios
macrumors G4
 

 
Join Date: May 2008

Quote:

Originally Posted by Ruffian829 
Anyone know if/how I can save a .webarchive file as a PDF or JPEG? 
I just want to be able to view the page when I'm not on the internet, and if the page ever gets deleted I want to
be able to keep a copy. 
The page is an iCloud journal my brother made for my son's birthday, so it's composed of a bunch of images. I
realize that I can save the individual images but I'd like to keep a copy of the collage as well.

How many web pages are involved?

Last edited by GGJstudios; Apr 16, 2012 at 10:34 PM.

       

 Apr 14, 2012, 07:25 PM   #11

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

Quote:

Originally Posted by GGJstudios 
How many web pages is involved?

It's one page but from what I can tell because it's a collage of photos from iPhoto iOS journal whenever you click on the
photos they appear in full screen- would those full screen shots = an additional page? 
I just want a copy of the one full main page (I don't need the full size individual photos)
I can link the page if that would help?

       

 Apr 14, 2012, 07:27 PM   #12

GGJstudios
macrumors G4
 

 
Join Date: May 2008

Quote:

Originally Posted by Ruffian829 
It's one page but from what I can tell because it's a collage of photos from iPhoto iOS journal whenever you click
on the photos they appear in full screen- would those full screen shots = an additional page? 
I just want a copy of the one full main page (I don't need the full size individual photos)
I can link the page if that would help?

It may not be the most elegant solution, but you could take screen captures of the page... take one, scroll down a page,
take another, etc. Then you could join those shots in one long .png file. Also, if saving as a .pdf didn't work, you might
try installing CUPS-PDF and then File > Print from Safari to the CUPS-PDF "printer".

       

 Apr 14, 2012, 09:32 PM   #13

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

Quote:

Originally Posted by GGJstudios 
It may not be the most elegant solution, but you could take screen captures of the page... take one, scroll down
a page, take another, etc. Then you could join those shots in one long .png file. Also, if saving as a .pdf didn't
work, you might try installing CUPS-PDF and then File > Print from Safari to the CUPS-PDF "printer".

How do I paste the screen captures together to make a .png file? 
You would think apple would have came up with a decent way to save journals! And not have to be tied to the internet
to view them!

       

 Apr 14, 2012, 09:42 PM   #14

GGJstudios
macrumors G4
 

 
Join Date: May 2008

Quote:

Originally Posted by Ruffian829 
How do I paste the screen captures together to make a .png file?

There may be apps that can do this easily. While not elegant, here's one method that will work. Let's say you have 10
screen captures that are 1000 pixels wide and 700 pixels high.

1. Start by taking another screen cap of some blank white space... any size.
2. Open that screen cap in Preview and use Tools > Adjust Size to change the size of that image to 1000 pixels wide

by 7000 pixels high.
3. Now save that image as your "canvas", giving it a filename, but leave the image open.
4. Open the first of your 10 screen captures in Preview, then Command-C to copy it.
5. Click on your "canvas" and Command-V to paste.
6. Position that image at the top of the "canvas" and Command-S to save changes.
7. Open the next of your 10 screen captures in Preview and Command-C to copy it.
8. Click on your "canvas" and Command-V to paste.
9. Position that image immediately below the previous image and Command-S to save changes.

10. Repeat steps 7-9 for each of the screen captures.

       

 Apr 14, 2012, 10:15 PM   #15

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

I tried to download that program and it didn't seem to download correctly (this may be me missing something really
stupid...). I get the installation package and go through the installation, says its installed and then nothing happens. I
cannot find the actual application anywhere. I tried quicksliver and spotlight search and all I can find is the .zip file and
the installer...

       

 Apr 14, 2012, 10:28 PM   #16

GGJstudios
macrumors G4
 

 
Join Date: May 2008

Quote:

Originally Posted by Ruffian829 
I tried to download that program and it didn't seem to download correctly (this may be me missing something
really stupid...). I get the installation package and go through the installation, says its installed and then nothing
happens. I cannot find the actual application anywhere. I tried quicksliver and spotlight search and all I can find
is the .zip file and the installer...

After you install it, restart your computer. Then, when you want to print to a .pdf, simply select File > Print from any
app, then click the dropdown menu showing your list of printers and select CUPS-PDF as your printer.

       

 Apr 22, 2012, 01:47 PM   #17

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

I still can't get this to work very well  If anyone is willing to take a shot, here's the link to the website:
https://www.icloud.com/journal/#p=02....jb/index.json

       

 Apr 22, 2012, 03:00 PM   #18

Dave Braine
macrumors 65816
 
Join Date: Mar 2008
Location: Warrington, UK

Yep, see what you mean about saving as a PDF. Have you scrolled down the webarchive file? I saved in that format and
got that "this journal is unavailable" notice. However, scrolling down most of the photos were there, just everything
above the row where the 18th Feb appears was missing.
__________________
PPC Mini, 10.4.11, Intel Mini, 10.6.4, White MacBook 10.6.4
Mk1 iPhone 3.1.3, using o2 PAYG

       

 Apr 22, 2012, 07:41 PM   #19

Ruffian829
Thread Starter
macrumors regular
 
Join Date: Jun 2008

Quote:

Originally Posted by Dave Braine 
Yep, see what you mean about saving as a PDF. Have you scrolled down the webarchive file? I saved in that
format and got that "this journal is unavailable" notice. However, scrolling down most of the photos were there,
just everything above the row where the 18th Feb appears was missing.

Yea I cant scroll at all, there isn't even a scroll bar, it just says "this journal is unavailable" :-/
honestly, you'd think Apple would have made a way to save these!

       

 Yesterday, 08:00 PM   #20

CrickettGrrrl
macrumors member
 
Join Date: Feb 2012
Location: B'more or Less,
"Potterville on the Patapsco"

Quote:

Originally Posted by Ruffian829 
How do I paste the screen captures together to make a .png file? 
You would think apple would have came up with a decent way to save journals! And not have to be tied to the
internet to view them!

In case you haven't solved this puzzle yet, I was reading another thread just now about how to easily arrange a bunch
of image files in Preview and save to PDF.

If you take a series of screen shots as GGJ Studios suggested, here's the info to combine them pretty quickly into one
PDF rather than copying & pasting each one separately into a large Preview file (from altoidboy btw):

Quote:

Easy way to do it in Preview:

1. Open all JPG's (or PNG's, or other graphics files) in Preview.
2. Make sure sidebar (showing thumbnails of each page) is visible.
3. Make sure order of JPG's is correct (if not, drag them into the order you want).
4. Select all thumbnails (shift-click is an easy way).
5. File > Print Selected Images (caution: NOT just "Print" but "Print Selected Images")
6. Lower left corner > Save as PDF.

       

 Today, 03:39 AM   #21

Tumbleweed666
macrumors 6502a
 
Join Date: Mar 2009

I think you'd be better off with an app that does this, unless its just a one off.

a quick google "mac app to download website for offline reading" found "site sucker" (never used it myself its just an
example) and many others
__________________
24" Aluminum iMac, 2.66 GHz, 4 GB RAM, 640 GB HD, OSX 10.6

       

 Today, 08:56 AM   #22

Darth.Titan
macrumors 68020
 

 
Join Date: Oct 2007

Quote:

However, you can always do a Print>Pdf>Save as PDF. You can do that from the webpage without saving as a
webarchive first.

You should read the thread before posting. That's been suggested already, and in this case it definitely doesn't work.

Last edited by balamw; Today at 09:06 AM. Reason: Image tracking spam removed from quote

       

 Today, 09:14 AM   #23

Apple Key
macrumors Demi-God
 
Join Date: Jan 2012

The app you are looking for is called Papparazzi!.
__________________
You know what they say... once you go Mac you ain't never gonna go back.
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